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Chapter 1

INTRODUCTION TO GIS



What is a Geographic Information System?

“A GIS connects where with what” 
A Geographic Information System collects, stores and manages the location and geometry of features 
(the “where”) along with the atributes of those features (the “what”). By utilizing computer 
technology, this connection between where and what allows for powerful analysis and decision-
making support.

The basic building block of a GIS is a “feature”
A feature is a computer model of a real world object (e.g. a river) or a concept (e.g. a boundary). Te 
computer model consists of one or more coordinates (x, y, z or latitude, longitude, altitude). 

A feature1 may be a single point in space or an ordered list of points (line2). A line may be closed to 
form a surface (polygon3). Tere is also fourth type of feature used to display images (e.g. satellite 
photographs) called “raster images” in combination with the above “vector” features4.

Features can be more complicated in that a single feature can consist of multiple parts. Lines may 
have breaks and polygons may have additional disjoint parts (separated surfaces that are identifed 
as the same object). Polygons may also have any number of holes (called islands)5.

1 Te term feature is unfortunately used a lot in sofware and technology to describe a specifc beneft of a product, i.e. 
central locking in a car is a “feature” of the car. In GIS, feature is the term for an identifable object on a map (more 
accurately defned above). When describing the sofware itself, alternative words like “function” must be used in the 
GIS world.

2 A “line” is technically a connection between two points, but in GIS “line” is short for “polyline” (multiple connected 
points).

3 A “polygon” in GIS is a closed polyline, but it is usually the surface area enclosed by the polygon which is being 
modelled. With polygons, a GIS more ofen answers the question: “is a point inside or outside of the polygon?” than 
the question “what is the surface area’s boundary?”

4 “Raster” means a rectangular grid of pixels (cells), where each pixel is a colour or other (e.g. elevation) value. “Vector” 
here means a mathematical model of a shape (feature). Raster images are actually positioned with vector rectangles.

5 And islands can have internal surfaces, which may again have islandss
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Atributes
Each feature has a unique number (called a FeatureId). Each feature may have a label (text to display 
on a map) and a measurement. Point features may have an orientation, line features have lengths 
and polygons have perimeters as well as surface areas. Areas and perimeters/lengths are 
automatically calculated and updated by PlanetGIS.

Any piece of information connected to a feature is called an atribute. Some atributes may be unique
identifers (called keys) that can be used to retrieve information from a database or spreadsheet or to 
be used to locate the feature. A user-defned identifer or code is an example for a key, and PlanetGIS
has an atribute defned by default, named “Key1” that can be used for this purpose. (Additional 
atributes can be defned by the user and used as keys).

Photographs, sketches, documents, multi-media & web links are other forms of atributes.

Feature classes
Features are classifed into feature classes (e.g. rivers or roads) which may be further classifed into 
subclasses (e.g. paved roads or dirt roads). All features of a feature class have the same atributes and
subclasses may add more atributes to those of their parent class.  For example, features in a feature 
class “Rivers” might have an atribute specifying whether it is perennial or not. 

Features are also grouped into feature classes to use the same appearance on the map (colour, 
thickness, etc.) but through the use of thematic mapping, classifcations may be done based on 
atributes (e.g. perennial [solid line] or non-perennial [doted line]).

Map composition
A GIS map is built from a set of layers (called displays). Each display references either a feature class 
or a thematic layer. Te user can control drawing order, visibility and the minimum and maximum 
scale at which each display is visible.

Displays use styles to defne their visual appearance. Styles are collections of symbols, pens, flls & 
fonts.

Finally, views are diferent sets of displays that may be set up for diferent mapping purposes or 
themes for the same geographical area (e.g. water services are normally displayed separate from 
electrical services).

Advantages of using a GIS
Among many other things, a GIS enables you to:

• Capture & store spatial entities & their atributes.

• Visualize spatial data to reveal relationships, paterns & trends.

• Share information in a form that is easily understood.

• Manage updates to your database over time.

• Integrate with existing systems.

Summary of Concepts

Feature
A computer model of a real world physical object (river) or invisible concept (border).
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Feature types
Features can be points (single coordinate), lines (multiple connected coordinates) or polygons (closed
lines, possibly with holes/islands).

FeatureId
A unique number that identifes a feature within a database.

Atribute
Information atached to a feature. Can be a number, text, photograph, etc.

Key
An atribute that is indexed (and usually unique) which can be used to identify or locate a feature.

Feature class
Features of similar type belong to the same feature class. Specifcally, all features of a feature class 
have the same atribute felds. (Not the same atributes, which are data items, but atribute felds, 
which are spaces for entering & storing data items).

Thematic classification
Features can be classifed between diferent thematic layers, based on the values of their atributes. 
In PlanetGIS these are usually called “thematic queries” due to the similarity to a database query 
which can be a flter (sub-selection), grouping (classify by value) or ranges (classify by range).

View
A special “theme” or collection of map layers which has been set up for a specifc purpose.

Display
Displays are references to feature classes or thematic layers and an associated style. A view is a 
collection of displays.

Style
A style defnes the visual appearance of a display. A style is simply a named collection of drawing 
elements that can be used and reused for other displays. Drawing elements are pens, flls, fonts and 
symbols.

How to use this guide
Tis user guide was designed to be read in sequence, skipping any sections that you deem 
unnecessary at the time. Recent versions of this document is nearly identical to the PlanetGIS 
Training Manual. Te content was developed during three years of presenting hands-on training 
courses by the author. Over time the PlanetGIS training course was developed to be suitable to both 
beginners and expert users. Because of this, parts of this guide will go into more detail than is 
required for introductory purposes.

Tis guide therefore aims to be both structured training and a reference manual. Te beginner user 
should keep this in mind and skim over parts that are not immediately applicable to the user’s work. 
Wherever this guide goes into seemingly too much detail, the reader is reminded to take note for 
future reference. Content and index pages can be used to locate sections for future reference.
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Notes
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Chapter 2

INSTALLATION AND LICENSING



Installing PlanetGIS

Requirements
PlanetGIS requires the Microsof Windows operating system (NT/2000/XP/2003/Vista/7/8/10), a 
minimum of 512MB of available RAM and 30MB of hard disc space for installation. For installation 
to the Program Files folder, you will also need administrator’s privileges.

PlanetGIS can be run on Apple and Linux computers with the use of Wine, other emulator or a 
virtual machine1.

Downloading the installers
Te latest versions of PlanetGIS can always be found on the download page: 
htps://planetgis.org/download.php. If you have sofware licenses, download links will also appear 
on your profle page (htps://planetgis.org/profle.php).

For downloads other than PlanetGIS Explorer (see licensing below), you need a user account on the 
PlanetGIS website. Creating an account is free and can be cancelled at any time.

When you download any version other than Explorer, you will be sent a license key via email. Tis 
should arrive before your download completes. If not, you will see it on your profle page (link 
above).

Updating an existing installation
It is not necessary to uninstall an existing installation of PlanetGIS. Simply install the latest version 
to replace a previous version. Some people like to keep older versions in which case you can simply 
rename the “Planet?nn.exe” to include a more complete version number. When there is a switch to a 
new “major” version number, e.g. 5.0 to 5.1, the names of the executables will be diferent and you 
will have both versions installed. (See next paragraph). You can simply delete an older .EXE and the 
shortcuts you may have to it on your desktop, start menu, or task bar.

Multiple versions
Each successive version of PlanetGIS either fxes defects, improve functions or add functionality. 
(Ofen all of the above). New functions can ofen be negatively afected by opening (and saving) a 
project with an older version. Tis is because older versions cannot save any options and setings 
you specify, of something the older version doesn’t know about. For example, some new “widget” 
that can foat on top of a map, will be lost when saved with a version of PlanetGIS that doesn’t know
about the new “widget”. In reality, this is rarely a problem if you have multiple versions starting with
the same whole number. (E.g. mixing 5.0 and 5.1 will in most cases not be a problem, but avoid 
opening a project that has been modifed in 5.1, with, e.g. 4.3).

Installation procedure
Installation normally takes a handful of seconds and about as many clicks. Installation fles will look 
like one of the following:

• Planet51Install.exe

• Planet52Trial.exe, or

• Planet53_64Install.exe

1 See the FAQ on the PlanetGIS website for your options: htps://planetgis.org/faq.php?za&faqtype=1#25
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Te numbers provide the major version number, and _64 means it is a 64-bit installer fle. Unless you
are using a 64 bit installer, make sure you choose the 32-bit location for program fles. (Normally 
C:\Program Files (x86) on 64-bit systems).

For PlanetGIS Explorer (installer fle starts with PlanetEs) you need to enter any further 
information, your installation should start and complete in a few seconds.

Other versions of PlanetGIS require you to enter a user name (any name of your choosing), an 
organization name and a license key. Te later two must be entered exactly as supplied (though 
capitalization and spacing is ignored).

Using PlanetGIS without an installers
If you do not have access to C:\Program Files (e.g. no administrator’s privileges), you can install to
any other location allowed by your operating system, e.g. D:\PlanetGIS. If you don’t want to use an
installer (or move/copy an installation from one computer to another), simply copy everything in the
C:\Program Files (x86)\Planet GIS2 folder to another computer. You can launch PlanetGIS by 
double-clicking on the .EXE fle. Be sure to also copy IJL15.DLL and SQLITE3.DLL. Planet will work 
for most projects without any of the other fles.

Tis is most useful when sending someone a GIS project on fash drive or external hard drive. 
Sometimes users do not want to install additional sofware, or do not have permission to do so. Tey
can simply double-click on the Planet?nn.exe fle to run PlanetGIS! You can also create a shortcut on 
the desktop (and elsewhere) to include the name of a project fle (.MAP), so that the map will be 
automatically opened. (Be sure to enclose the whole path to the .map fle in double-quotes if there 
are spaces in the path).

Sofware licensing

Free sofware
PlanetGIS Explorer is completely free. With “Explorer” you can set up GIS projects, change the 
appearance of maps and even import information (e.g. from shape fle). PlanetGIS Explorer lacks the 
ability to capture features by hand. For this and hundreds of other advanced functions, you need 
Professional or Enterprise.

Trial sofware
You can download a trial version of PlanetGIS Professional or Enterprise, which will have full 
functionality until a predetermined date. Tis date is normally about 3 months from when the 
sofware was released. Afer this date you will not be able to save changes to your maps, though that
excludes captured features (captured/imported features are persisted to the database immediately).

Tis “expiration” is merely a reminder that you likely need a licensed copy for future productive use 
(see next section). You can still make changes with PlanetGIS Explorer (and save them). You can also 
download an updated trial version which will likely extend the expiration date. (Trial sofware is 
provided with a trial license, which includes 6 months of sofware updates and newer versions of the
trial sofware always have expiration dates set into the future).

Licensed sofware
If the functionality provided by PlanetGIS Explorer is not sufcient for your work, and you use 
PlanetGIS in your profession or for any for-proft project, you need to purchase a sofware license.

2 Note “(x86)” might not be part of the path if your operating system is 32-bit.
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Sofware licenses can be purchased from our website: htps://planetgis.org/order.php Please note 
that any data purchases do not include sofware licenses. (All data products can be used with 
Explorer).

A sofware license gives you access to priority email support and sofware updates for a year afer 
purchase. Tis includes “major” updates, not just improvements to your current (main) version.

Important: Licensed sofware does not expire. You will be able to use the sofware indefnitely. 
What does expire? Web updates (see below).

Educational or non-profit usage
In the majority of cases a trial version is sufcient for educational use. Every student can download 
their own trial sofware and request extensions if necessary. 

Other non-proft uses will be considered for unlimited free licenses.

Multiple users
Te PlanetGIS licensing scheme is per user. (Tere is no “network license”). Te license fee for 
additional users is steeply discounted. “Additional users” must be co-workers. Tis usually mean that
they are in regular contact with each other. Large organizations with groups in diferent locations 
must obtain a separate license key for each ofce.

Multiple installations by one user
Every user can install PlanetGIS on as many computers as required for use by that user. Tis 
includes e.g. additional laptops, tablets or home computers. While each installation must be 
registered (in order to update), there is no limit placed on registrations.

Ad-hoc users
Organizations may also install PlanetGIS for additional users that infrequently need access to the 
organization’s projects. Explorer is ofen sufcient for this, but other installations are allowed.

Sofware registration
PlanetGIS Explorer does not require any license key, registration or even a user account on 
planetgis.org. 

Other versions of PlanetGIS require you to register the sofware before you can update it to a new 
version. Tis requires you to have a user account on planetgis.org. Some organization use only one 
user account for everyone’s updates. Tis is quite acceptable, but it is easier to keep in touch with 
our users if every person creates their own account. Te process of sofware registration combines 
user accounts with organizations’ license keys.

If you have not registered each installation, you will be prompted to do so before installing a new 
version. All you need to register an installation is the email address used to create a user account on 
planetgis.org and your 5-digit password. (Your password will be in an email sent by the system when
you created an account. Tere is also a “Forgot password” link on the website to have it emailed to 
you again).

For quick, online registration, you need to have Internet access on the computer with the sofware, 
and the PlanetGIS sofware must be allowed by the frewall to send and receive information to 
planetgis.org or planetgis.co.za.

To register your PlanetGIS installation, click Help→Register soffare.
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Sofware updates

Automatic checks
PlanetGIS will occasionally, on startup, atempt to contact the PlanetGIS website to see if a newer 
version is available. If your system’s frewall allows such check, PlanetGIS will notify you if any 
updates are available. You can also see the updates in a list, in order to decide if updating is 
necessary. You can manually check for updates by clicking Help→Check for updates.

Web updates
Web updates provide the latest versions of PlanetGIS to users with active update subscriptions. 
Updates are downloaded from the PlanetGIS website and then installed on client computers. Web 
updates are active:

• For one year afer purchasing a sofware license

• For 6 months afer obtaining a trial license

• For subsequent years upon purchasing web updates

• For one year afer purchasing an upgrade (see below)

Additional years of web updates cost 25% of the cost of a new license. When web updates are 
renewed, the previous period’s updates are extended by one year. When purchasing web updates 
afer the expiration period, therefore, will extend the update period for one year since the last expiry
date, not the date of purchase.

Ad-hoc upgrades
Web updates are optional. An alternative is to purchase an upgrade when the user is ready to move 
to a newer version of PlanetGIS. An upgrade of a license is always 33.3% less than the full price at 
the time of purchase.

Important: An upgrade does include one year of web updates.
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Chapter 3

GETTING STARTED WITH PLANETGIS



Introduction
In this section you will be introduced to all the essential elements for using and customizing an 
existing PlanetGIS project and to produce output from it. 

Opening a GIS Project
PlanetGIS project fles have .map extensions.  In this guide, the
word “map” will sometimes be used as a short form for “PlanetGIS
project”.

When launching PlanetGIS, you will be presented with a “Qick
start” window which lists all your recently opened projects.
Alternatively use the File menu which also maintains a list of
recent projects. Te following examples use the World map which
is available here: htp://www.planetgis.co.za/browsemap.php?id=12

Files used by a PlanetGIS project
PlanetGIS project (.map) fles store the structure of the project, all setings like styles,  database 
connections and references to other projects. No spatial or atribute data is stored in a .map fle. 
When you save a PlanetGIS project, you are saving changes to the .map fle.

Spatial and atribute data is stored in a database (.db) fle, with the same name as the .map. If the 
.db fle is not present in the same directory as the .map, it will be regenerated but will not contain 
any features or atributes (the map will appear blank).

Te .map and .db fles are the most important and must always be kept and distributed together. 
Other fles that will be created automatically if they are not present are:

• .f2d – Two-dimensional spatial index used for drawing the map. If not present it will be 
created from the geometry of features stored in the .db fle.

• .q2d – Two-dimensional spatial index used for drawing thematic layers of a map. Tis fle is 
separate from the .f2d because it is regenerated ofen.

• .db-jpg – A database for storing photographs and panorama images. Tis fle is separate 
from the main database for easier regular backups of the main database.

• .db-doc – A database for storing documents and multimedia content. Tis fle is also 
separate from the main database for easier regular backups of the main database.

• .db-log – A database that keeps track of all changes made to the other databases. All 
changes and additions to features, atributes and content are logged. Tis fle can be used to 
synchronize changes made on multiple copies of the same project. Tis fle can be deleted at 
regular intervals.

Locations for PlanetGIS projects
PlanetGIS project fles need to be together in a folder (directory) on your local hard drive, a network 
drive or external storage. PlanetGIS must be able to create fles in this folder. It is therefore not a 
good idea to create folders for your projects anywhere under C:\Program Files or (C:\Program 
Files (x86)) because Windows typically restricts sofware from creating their own fles in this 
location. An easy location like C:\PlanetMaps works well.
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The .backup folder
Every time a project is saved, the .map fle is overwriten. To guard against accidentally saving a 
change which is undesirable, a backup is created in the .backup folder. Every backup will have an 
incremental number appended to the .map extension following a semi-colon. Only the 10 most 
recent backups are kept (older ones are deleted) with the exception of the very frst backup that was 
made which will have a .map.0 extension.

To recover a backup, simply delete your project's .map fle, copy the backed-up version that you 
want to restore (the fle's date will be the best indicator for which version to choose) to the project 
folder and rename it so that the extension is .map.1 Do this while PlanetGIS is closed (or the project 
is closed) and re-open the project when you're done.

Do not rely on this function for your backups, since spatial and atribute data are not backed up in 
this way. You must have a system in place for making regular, if not daily, backups of projects that 
are being actively worked on.

The User Interface

If you pause the mouse over most elements shown above, a small “tool tip” will appear that explains 
the element's function. A longer explanation will appear in the hint bar at the botom. Te frst six 
butons of the map toolbar are mutually exclusive “click modes”. Each changes the way that the 
mouse will interact with the map. When the mouse is over the map, notice how the hint bar tells 

1 By default, recent versions of Windows do not display the extensions of fles but rather the type of the fle which may 
be diferent than the extension. Change your folder options to display the extensions of fle names and save yourself 
much agony in future.
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you how you can use the mouse to interact with the map. A mouse with a wheel is recommended. 
Rolling the wheel will change the position on the scale bar, zooming in or out with the location at 

the mouse cursor remaining stationary. In zoom mode ( ), clicking on the map will move the 

map so that it is centred around that location (and zoomed in). Right-click zooms out. 

In all modes, right-click and hold the mouse buton down for ½ second to see a menu with many 
useful items.

Map toolbar

 Tag: In this mode a map feature is selected while the existing selection is cleared. <Ctrl> 
changes the click mode into “Tag multiple” and <Alt> changes it to “Untag”. Click this buton and 
hold the lef mouse buton down for ½ a second to open a palete of additional tagging modes.

 Info: Tis mode is the same as Tag mode except that the atribute information window pops up 
on top of the map every time you select a feature. Use Tag with the Info tab instead unless you 
have a large or multiple monitors.

 Measure: In this mode you can measure distance, direction and area. Click once on the map to 
indicate the starting position of a measurement and move the mouse in the direction of 
measurement. Te distance from the start location, direction and bearing is displayed in the scale 
box. Te total distance will be updated continually as you move the mouse. Click one or more times 
to fx a coordinate and create further line segments. If you keep the mouse buton depressed, a path 
will be captured with many points as you move the mouse. To measure area, return to the starting 
point. Clicking at the starting point clears the measurement polygon. Te <Esc> key cancels the 
current measurement.

 Capture: In this mode you can place your own points, lines or polygons on the map. Click on 
the buton and hold the lef mouse buton down for ½ a second to open a palete of additional 
capture tools.

 Zoom: In this mode you can click on the map to centre that position and reduce the scale by ¼, 
or alternatively click and draw a zoom rectangle by moving the mouse while keeping the the lef 
mouse buton down. Right-clicking – as with most other modes — will zoom out by doubling the 
scale.

 Pan: In this mode you can change the viewing location of the map without changing the scale. 
Click on the map and drag (move mouse while lef buton is held down) to “pan”.

Te next 5 butons do not change the click-mode selected above. Tey all perform a single action 
which usually do not need to be repeated.

 Zoom all: Display the map to its full extent or if the maximum extent is limited, zoom-all will 
go to that limit.

 Zoom previous: Revert to a prior location and scale. Tis is similar to “undo” for zooming and 
panning operations. All locations since opening the map is remembered.

 Zoom tags: Fit selected features onto the screen, zoomed in as close as possible.

 Clear tags: Clears all tags and empties the selection.

 Redraf: Re-renders the map on screen.
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Menu toolbar
Te butons at the top are shortcuts for items in the main menu.

File & print
Butons correspond to items in the File menu:

 Nef: Create a new PlanetGIS project.

 Open: Open a PlanetGIS project.

 Save: Save changes to the active project. (Te icon is a dull colour when no changes have been 
made and turns bright once a change has been made to the active project).

 Save all: Save changes to all changed projects currently open. (Colour change indicates that one
or more of opened projects have been modifed).

 Print previef: Changes the view mode to visualize the map as when printed on paper as per 
the currently selected printer and page size and orientation. (File→Print setup to change). Click 
again to change to normal map view.

 Print: Prints current view at current scale.

Application interface mode

 Map: Te map is visible (default mode).

 Design: Design mode exposes the entire structure of all open projects. Ofen operations are 
more efcient in this mode.

 Database manager: Direct access to the internal as well as linked databases.

Map tools
Common mapping actions, e.g. locating features which will be demonstrated later in this guide.

Expanding tabs
Te tabs on the right of the user interface expands once you click on them and can be collapsed by 
the small arrow at the top. Each tab serves a diferent purpose as explained below. Te content of the
tabs are determined by the currently active view and the current selection of features on the map.

If enough vertical space is available the names of each tab will be visible, alternatively only the icons
are displayed and you have to move your mouse over each to see the tab’s name.

Te expanded area of the tabs can be resized by dragging a “spliter” between the tabs’ content area 
and the map scale trackbar. 

Legend: Legend display for the current view at current scale. Exactly the same content as the 
legend that could be displayed as a foating object on the map or inside a print frame.

Displays: Te Display Manager controls what displays are added into a view, which displays 
are visible, the order of displays and more.

Selection: Shows exactly what has been selected on the map, and counts by feature class. Can 
be used to refne the selection.
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Info: Displays all atribute information of selected features. Can also be used to change the 
selection on the map.

Documents: Displays all documents linked to selected features. Documents can be viewed, 
added and deleted.

Photos: Displays all photographs linked to selected features. Photographs can be viewed, 
added, deleted and manipulated.

Sketches: Displays sketches linked to the selected feature. Hand-drawn sketches can be linked 
to features, viewed or deleted.

Input: A custom input area that can be defned for each feature class. Te input felds 
correspond to the display on hand-held data collection devices.

Edit: Tools for making changes to a selected feature.

Pan & scale trackbars
Use the East-West and North-South pan bar directly next to the map area below and to the right to 
“pan” the visible area of the map as desired.

Te scale trackbar has levels of rounded and commonly used scales. Te scale trackbar corresponds 
to each position of the mouse wheel when rolled forward or backward slowly. (Te mouse wheel 
will skip scale levels when rolled continuously for speeding up zooming).

The status bar
Te status bar at the botom of the screen has four areas:

• Hint bar: Displays hints and descriptions based on the location of your mouse cursor. On the
map the hint will described commonly used actions that you can perform with your mouse, 
based on the current mode of operation. Outside of the map, the hint will describe the user 
interface element (buton, tab or menu item).

• Scale: Current scale of the map. Click to change to a specifed scale.

• Coordinate: Te map coordinate of the mouse cursor. Click to change the format.

• Coordinate system: Te name of the coordinate system of the active map. An asterisk at the 
end indicates a secondary coordinate system (not the actual coordinate system of the map).

Views
A PlanetGIS project has at least one view and by default this view will
have the same name as the project. You can create any number of
additional views of a map. Views are shown as tabs at the top of the
map. When selecting a diferent view, the same geographic location is
displayed but with a diferent set of displays (and usually a diferent
appearance). Tere are two main reasons for creating multiple views:

1. To display diferent themes (e.g. displaying population instead of land cover or separating 
e.g. water utilities from electricity).

2. To set up views for specifc purposes. You may want separate views used for printing and it 
is a good idea to have special views for capturing features.

To manipulate views, right-click on a view tab (Figure 5 shows how to add a view).
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Figure 4: View tabs



Views can also be created in a hierarchical structure where
you have views within views. An ellipsis (s) will indicate
that a view has sub-views. Tis is useful to reduce the
number of top-level tabs, create a logical structure and re-
use a group of displays. For example, you can have your
background displays (e.g. country borders) in a parent
view and diferent themes overlaid in sub- or “child” views2. By default child views will frst draw 
the displays of parent views. Tis can be switched of in the view's properties.

Te “Select view” buton in the menu bar ( ) also lists the views and is mostly helpful only if 

there is a hierarchy of views.

Displays
Displays are similar to layers in Computer Aided Design (CAD) sofware. In
PlanetGIS, a display is a reference to a feature class or a thematic layer
(classifcation). A view is a collection of displays. A display acts as a link
between a view and a feature class or a thematic layer3.

Te visual appearance of features is determined by the style that is selected.
While feature classes and thematic layers have their own default styles, the
display ultimately defnes which style is to be used for a layer in a particular
view. A display therefore also acts as a link between a layer and a style.

Displays have many properties that control when and how to display a layer
and how features are labelled.

Te visibility of layers is indicated by the eye icons and controlled by clicking
on the eye icons. Te yellow question mark indicates that a display's visibility
is dependent on scale. As you zoom in on the world map, you will see more
“eyes opening” in the “Places” group. 

Figure 7 shows a popup menu when right-clicking on an “eye”. Here you
can use “Show all” or “Hide all” for controlling the visibility of all displays
in a group.

Adding displays into a view
You can click anywhere on the white space in the Display Manager or
right-click on a display to add displays. Figure 8 shows the selection of
two feature classes to add to the display list. Multiple selection is done by
holding in [Shif] or [Ctrl].

2 Te terms “parent” and “child” are from mathematical and computing “graph theory”, which is a system of organizing 
information into a “tree”. Te tree starts with a “root” node which has sub-nodes (also called “child nodes”). Te 
“parent node” is one level up in the hierarchy. You will fnd this concept almost everywhere in Planet, so you will soon
be very familiar with parent-somethings and child-somethings.

3 We will use the word “layer” to refer to thematic classifcations and sometimes feature classes. PlanetGIS doesn't have 
the concept of layers as does CAD sofware, but a display works similarly to a layer and for thematic queries, the 
ranges, groups or flter, in efect, form separate layers.
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Figure 7: Switching of all displays in a
group

Figure 6: Te Display Manager

Figure 5: Adding a view



Ordering displays
Displays are listed in the order in which they are drawn. Te
topmost display is drawn frst and so on. If you think of displays
as layers, the topmost display is the botommost layer. However,
by default, Planet uses “smart draw ordering”. Planet will frst
draw all raster images, then flls (of polygons) then
lines/outlines, then symbols and lastly text (labels). Within each
of these steps, displays are drawn in top-to-botom order. As an
example, if you drag the “Landcover” display to the botom of
the list, the map will look the same: the land cover raster image
does not obscure anything.  If you switch of smart draw
ordering, the landcover will obscure everything else. It is
therefore good practice to place raster displays at the top of the
display list. (“Smart draw ordering” can be switched on and of
in the view’s properties [right-click on the view tab]).

With smart draw ordering switched on (the default), only the order of displays with similar style 
elements are important. For example, in the World map the “Sovereignty” display (switch it on if you
want to test) must be before (above) the “Urban areas” and “Lakes & dams” displays, otherwise the 
later will be obscured by it. Similarly, if you want one display’s pen to be drawn on top of another’s 
that display must be lower in the list.

To change the order of displays, simply by drag them to a new position. Care
needs to be taken with grouped displays and this applies to many other places
in Planet where items can be dragged to new positions: if you drag-and-drop a
display onto another display that is a group of displays, the dropped display
will go inside the group. Figure 9 shows dragging of a display to the right of a
group display. Tis will place the “States & provinces” display afer “Places”
instead of inside.

Display properties4

Figure 10 shows the General tab of the display
properties. On this tab you can change the
display's name (if required to be diferent
[perhaps more descriptive] than the name of
the feature class), select a diferent feature
class and select a diferent style.

Tere are many setings & options (properties)
for displays. In this section we will only look
at the visibility tab. Here you can make a
display to be “scale conditional”. Tis is
immensely useful to speed up map rendering
and de-clutering maps containing lots of
features. Also, Figure 10 shows a second item
in the menu (“Style propertiess”) which is a
shortcut to take you directly to the assigned

4 Nearly everything in Planet has “properties”. Properties are setings or user options that are stored for each item. In 
this guide we will ofen use a phrase like “in the something properties” which will mean: “in the window (dialog box) 
that displays all the options and setings for this something”. You can almost always right-click on an item to see a 
popup-menu which nearly always will have “Propertiess” as the frst item.
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Figure 9: Avoiding dragging a 
display into a group

Figure 10: Display Properties window / dialog box

Figure 8: Adding a feature class as a display



style.

Styles
A style is simply a named collection of style elements. Tere are
four types of style elements:

• Pens
• Fills
• Symbols
• Fonts

A style can have any number of these elements. In Figure 11
there are two pens: one is used for small scales (global,
continental) and the thicker, coloured pen is used for larger
scales (when only one or a few countries ft onto the map)5. You
can also specify a style element specifcally and exclusively for
printing, on-screen or quick display. Te efect of individual style
elements is determined by a complex set of conditions.

All feature types (points, lines, polygons) can display a label (using a font) and a symbol. A symbol 
will be used to display a line or polygon that hasn't any visible pens or flls. Tis is sometimes useful 
when you need to show lines and polygons at a small scale where they would be invisible otherwise.

In some cases it is useful to only see the label of a line or polygon feature (e.g. the name of a 
mountain range). To accomplish this, pens and flls need to be invisible at the current scale and the 
display properties need to have “label invisible features” set.

Only polygons will use flls and only polygons and lines will use pens.

Common aspects of style elements

The Colour Picker
Planet has an extremely capable colour selector (/picker).
Te “colour wheel” provides the full range of colours at a
particular “lightness” (/shade). Click anywhere on the
wheel to select a colour. Slide/click on the “lightness” bar
to select a shade (amount of black mixed in for the colour
wheel). Te centre of the colour wheel is achromatic (a
shade of grey).

Alternatively, click on a coloured or grey-scale cell in the
“quick pick” area. You can also build your own palete of
ofen-used colours by clicking on “Custom palete”.

For precise colour selection, you can enter either Red-
Green-Blue values between 0 and 255 or Hue-Saturation-
Value values. Sliding any of the 6 black triangles to the
lef or right is an efcient method to adjust a colour to
your liking. R-G-B corresponds to how colour is mixed on
a computer screen and H-S-V corresponds to how colour

5 Te terminology “small scale” and “large scale” can be confusing because a small scale has a large number in the 
second part of the one-to-number ratio (1:n). A small scale (e.g. looking at a whole continent) could be 1:10 000 000 
while a large scale (e.g. looking at a suburb) could be 1:10 000. Mathematically, it makes sense when you realise that 
scale is a fraction of 1, i.e. the fraction 1/n.
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Figure 11: Te Style Properties window

Figure 12: Advanced colour picker



is mixed by a printer.

Hue is a value between 0 and 359 which corresponds to the degrees of arc around the circle that is 
the outer edge of the colour wheel. Red is at 0 degrees, green at 120°, etc.

Saturation is a measure of how much white is mixed in (tint). A fully saturated (pure) colour is on 
the outer edge of the colour wheel, while the centre of the wheel has no colour. Changing saturation
changes the distance of the selected colour between the centre and the outside of the colour wheel. 
For printing, you would typically reduce Saturation if a colour is too bright (and to save ink). 

Value is a measure of how much black is mixed in (shade). Changing Value (or lightness / shade), 
changes the entire colour wheel, similar to how all available colours will appear darker in low light 
conditions. Text and lines that need more contrast to stand out will typically need a reduction in 
Value, while solid flls will typically need a reduction in Saturation.

Te “Dropper” sampler

Te “dropper” is a very convenient tool to select a colour from something else already displayed on 
your screen. It is a good alternative to building your own custom colours (palete) if you want to 
restrict the colours that you are using to a fnite set.

Click on the dropper buton and then anywhere on the map or any area that is part of Planet to 
select the same colour. To pick a colour from another application you need to have both Planet and 
the other application visible on the same screen (or on multiple screens). Planet needs to keep the 
focus to sample the colour, so the procedure is slightly diferent: click on the dropper buton and 
keep the lef mouse buton down; move the mouse to the colour you want sampled; only release the 
lef mouse buton once you have the desired colour under your mouse cursor. 

Visibility
Every style element has the option for displaying either for on-screen, printing or quick display. In 
addition every element can be selected to display for a range of scales. For styles that have child 
styles (for use with groups of feature classes or thematic queries with sub-groups of either groups or
ranges) a parent style can be made to be applicable or not. 

Units of measurement6

Te width and height of pens, fonts, symbols, etc. can be specifed in either “paper units” or “real 
units”. Paper units are fxed, while real units are real-world dimensions. For example, if you set the 
font for street names to “8m (real)” the street names will always have the height equal to roughly the
width of a residential street. Tis can be useful at large scales, but the street names will soon become
invisible as you zoom out to smaller scales.

Never use px (pixels) if you intend to print your map. On a typical screen, one pixel is about 0.25mm 
but on a typical 600dpi printer only about 0.04mm.

Font properties
Fonts are a combination of a typeface, a style, size, colour and efect. Te Typeface is the name of the
font given by the designer (e.g. “Times New Roman”, “Arial”, “Georgia”, “Helvetica”, etc). Te style 
can be a combination of italic, bold and underlined.

6 If you are seeing inches selected by default and you are not in the U.S.A. it means that your computer's locale is set to 
U.S. or measurement units is set to “U.S.”. Change this in Control Panel, “Clock, Language, and Region” and set your 
location, or alternatively click on “Additional setings” in the Region and Language window and change the 
measurement system to “Metric”.
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Fonts can also have a background efect to make them more visible. You can specify a solid colour 
for a background, a “halo” of lighter colour can make text more visible as well as a shadow. Tere is 
also an option to draw a box with an outline and fll around the text. 

Symbol properties
Symbols can be either vector shapes or bitmap images. Shapes have the advantage of producing 
symbols at the maximum quality allowed by the output device/printer. Bitmap images have the 
advantage of having unlimited colours. Planet includes about 300 shapes. Click on the shape buton 
to select a shape. Expand the “WSP” tree node to see groups of shapes.

It is also possible to create your own shapes by capturing features and importing them as shapes.

Pen properties
Pens can be either “hairline”, “solid”,
“patern” or “shapes”. Hairline implies a
width of one pixel. Do not choose hairline
if you will be printing your map. Hairline
pens do have the advantage of being very
fast. Since pens are typically used on a
large amount of coordinates, thick pens
can slow down the drawing of your map
considerably. A possible solution to this is
to have separate pens for “browsing” than
for “printing” (set this in the “Visibility”
section). 

Patern and shape pens can become quite
complex as seen in Figure 14.
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Figure 13: Te font properties window

Figure 14: A complex pen using shapes on vertices



Fill properties
Fills can be either “solid”, “transparent”,
“hatch” or “shape”. For transparent flls,
you supply a value between 0 and 100%
for “opacity”. 0 is completely transparent
(invisible) and 100 is completely opaque
(non-transparent). Good values for
opacity are 25 and 507. Please note that
transparent flls do not work in PDF
documents. Tey do work very well in
XPS documents.

Tere are a large number of hatch paterns to
choose from. For a “hatch fll”, click on the hatch
buton to select a patern. A shape fll uses shapes,
normally used for point symbols, spaced out
horizontally and vertically per user specifcation.

Locating features

Click on the Find buton ( ) to locate a feature.

With the top node (“World Map.map”) selected, the frst 1000 features of the map is displayed. 
Simply click on a row to select the feature in the background. Use [Ctrl] or [Shift] to select more 
than one feature. 

7 Planet uses a “dither patern” to simulate transparency similar to how printers do it. True transparency requires pixels 
to be blended with the background which means the entire image must be created as a bitmap prior to printing which 
is not practical. Tis means that transparent flls do not look as good on screen as they do when printed.
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Figure 15: An example of a hatch fll

Figure 16: A few of many available hatches



To narrow down a search, frst select a feature class on the right. As an exercise, select “Countries” 
and then locate “continent” in the long list of atributes (“continent” is near the botom).

Select “Africa” to narrow down the list.

You can add additional criteria: In the second dropdown list, locate the feld “gdp_md_est” (Gross 
Domestic Product in millions of dollars, estimated) and select greater than (>) instead of equals (=). 
Now type in a value of 1000000 to see a list of the top 6 economies in Africa (see Figure 19).

Te SQL tab of the results shows the actual SQL query used to fetch the results from the database.
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Figure 17: Locating a feature

Figure 18: Type one or more leters to get a list of values found in the database

Figure 19: Top 6 African economies found by additional criterion



Saved Locations
Saved locations are like “bookmarks” for a map. You can use Saved locations to return to a specifc 
place on your map and either at a specifc scale or a rectangular area.

If you are at a location which you would like to return to, save it by clicking on the Goto buton (

) in the menu toolbar. Notice that the Goto buton has two regions: the down arrow on the 

right will display a list of previously saved locations, if there are any (if not it will do the same as a 
click on the lef side). Te lef region of the buton is therefore actually “save this location”, not 
“goto”. 

Give the location a name that makes sense to you. Saved locations
have the following properties:

Activate view
If checked, the saved location is also tied to a view. Te selected
view (or current view) will be activated each time that you “goto”
the saved location.

Limit to this view
If checked the saved location is tied to the selected view in a diferent manner: It will only appear in 
the list if the selected view is active. Tis option allows you to have saved locations that are specifc 
to views. If unchecked, the saved location is always visible.

Options for how the location is stored
• “Save centre point & scale” - if the scale is more important than the extent.

• “Save visible rectangle” - regardless of screen or paper size the rectangular extent visible 
when saved will be ft such that (if the width/height ratio changes) either the width or the 
height will be exceeded but not both.

• “Save scale only” - a diferent kind of location which is not a location, but only a scale. Tis 
option is for when you are working at specifc scales and need a quick way to zoom to these 
scales while keeping the part of the map in the middle of your screen in the same place.

Limiting your project area
Each view can be limited to the extent defned by a
saved location. Right-click on a view tab and click 
Properties, then activate the “Activate/Limit” tab.

Check “Limit visible area” and select a saved location as
shown in Figure 21. In most cases where you have
separate views for distinct project areas, you would also
want to check “Zoom when activated” so that the entire
project area will be shown when you switch to the view.

A variation on this would be to zoom to a project area
without limiting the visible area. Tis would add the
convenience of zooming to the appropriate project area
without restricting the visible area (i.e. you can still zoom out to other locations/scales).
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Figure 20: Saving a location

Figure 21: Limiting a view to a saved location



Yet another variation is to use a (polygon) feature instead of a saved location. Figure 21 also shows 
the values for using the boundary feature of South Africa. Check “to feature” and enter those values 
to use the feature instead of a saved location.

Design Mode
“Design mode” is an alternate view of your opened projects – a “look under the bonnet”, so to speak.
Every single aspect of your project is accessible here. Design mode is analogous to looking at a 

database table's structure instead of its content. Click on the Design buton ( ) in the menu 

toolbar to activate Design mode.

Design mode consists of two panels separated by a “spliter” which you can move to assign more 
space to either panel as required. On the lef is a “tree” displaying the hierarchy of elements of your 
projects, starting with each project on highest level under the “root” which is simply called “Maps”. 
Tis tree is very similar to the folders view in Windows Explorer. Each item in the tree is called a 
“node” and a white-flled triangle8 to the immediate lef of the node indicates that the node can be 
expanded to reveal more (“child”) nodes. In Figure 22 you can see that the “World Map.map” and 
“Feature classes” nodes have been expanded. Te “Feature classes” node has also been selected.

Once a node is selected, you will see that the right panel contains either a list of data items or child 
nodes which are also in the tree view on the next level down. (Feature subclasses are shown in the 
“Subclasses” tab).

In general, Design mode has several very useful functions:

• Right-click on any node to see a menu of possible tasks for that node.

• Right-click on any node and click Properties to see all setings for that element.

• Create new elements or delete elements.

• Re-order elements and move elements into other elements.

• Create duplicate copies of elements.

• Copy any element to another project (simply drag-and-drop).

Other than displaying database information for feature classes, the right panel (or content panel) is 
useful for performing actions on more than one element at the same time. For example, you can 
select many elements and delete them all in one action, or copy them all to another element by 
dragging them onto a node in the tree on the lef. Tere are several ways to select more than one 

8 On some systems this is a block enclosing a plus.
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Figure 22: Design mode with "Feature classes" node selected



element:

• Select an element, then press <Shift> and select another element to include all elements 
between (from lef to right, then top to botom).

• Select an element, then press <Ctrl> to add individual elements.

• Position the mouse onto white-space (to avoid selecting something), then drag a rectangle 
touching all elements you require to be selected.

• To unselect individual elements that have been selected, press <Ctrl> and click on each.

• You can also use the drag rectangle method to unselect elements by pressing <Ctrl> when 
completing the rectangle-drag.

To return to mapping mode, click Map ( ) on the menu bar or double-click on the project node 

(“M:\World\World Map.map” in the example above). Tis will also activate the project if you have 
multiple projects open.

Notes
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Chapter 4

MAP PRODUCTION



Introduction
In this chapter you will learn how to set up existing projects for producing maps. Tis includes 
embedding maps into your documents, producing electronic (paperless) maps and paper maps.

All tasks in this chapter can be achieved with the free PlanetGIS Explorer.

Displaying a Map Grid
To display a grid (or “graticule” for a
geographic projection map), right-click
on the view tab as in the previous section
and click Properties. Activate the “Grid”
tab.

To display an automatic grid with text for
the values, select the items as in Figure 
23. A fxed grid can be specifed, but will
only be useful at a narrow range of
scales. Te grid interval can be specifed
in degrees, minutes or seconds (and
fractions thereof) or in the case of a
projected coordinate system (usually)
metres. On a World map, it is typical to
have a 15 degree grid (graticule). (15
degrees is one hour of the Earth’s rotation). If you forget to change from seconds to degrees, Planet 
will not display a grid because there would be too many grid lines.

If grid lines are too intrusive, select “Ticks only” which will draw short lines of the specifed length 
around the edges of the map and crosses where grid lines intersect.

Floating Objects
Floating objects are elements added to a map that remain in one place on the screen (or printed 
page), regardless of changes to location or scale of the map. To add a foating object, you need to 
open the map popup menu with a long-right-click (i.e. keep the right mouse buton down for ½ 
second). Figure 24 shows how to add a “foating” legend.

Typical types of content for foating
objects are:

• Text (e.g. a title)

• Image (e.g. a logo)

• Legend

• North arrow

• Scale bar

• Locality map

• Page references

Once you have selected the type of foating object, a “Floating object properties” window will 
appear. For this example, simply click OK.
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Figure 24: Adding a "foating" legend

Figure 23: Seting up a latitude/longitude grid



Sizing frames
As soon as you create a foating object, “sizing frames” will be automatically
switched on. You can click in the interior of a foating object and drag it to an
appropriate location, or drag the edges to adjust the size. 

When you close your project and re-open it, sizing frames will not be visible.
Tis is the default mode of operation so that you can interact with the map
without foating objects interfering. Te only interaction available without
sizing frames is right-clicking inside the foating object. To switch sizing
frames on or of, right click on a foating object and check/uncheck Sizing frames.

Right-clicking on a foating object also allows you to change its 
properties and hide or delete it.

Common properties of floating objects
Every type of foating object has the same properties window for common properties which are 
divided into tabs for:

• General. Te name (only for reference)
and type of content as well as access to
the specifc properties of the content
(see next section).

• Position. For specifying exact distances
from edges of the page.

• Size. For specifying exact or relative
sizes.

• Visibility. Choose which views to
display the foating object in as well as
whether it should be used for printing,
on-screen or both.

• Border. For specifying a frame to use
around the foating object and also what colour to use for its background (if any).

Specific properties of the contents of floating objects
You can access specifc properties for the type of foating object you have chosen in the General tab 
of the foating object's properties window.

Use the buton with the down-arrow to change the type of content or click on the content buton to 
open specifc properties.

Map Production 34

Figure 25: Dragging a legend

Figure 26: Floating object menu

Figure 27: Floating object properties; Border tab



Floating text
Floating text is normally used as a title for the map. When you create foating text, it will appear in 
the default location for a title. Move it to an appropriate location for other uses. 

For a title, your text size should be “auto” and alignment “centre” to size it to ft according to the 
extent of the foating object. For other uses you may prefer a fxed size and lef-aligned text.

As part of the text you can use the following “macros” for automatic/variable information: (all lower 
case, no spaces, preceded by $)

$viewname
$longdate $shortdate $time
$coordsys $projection $coordinate
$scale
$filename $fullpath

$viewname is handy to use the name of your
views as titles on the map. Te date format (as
elsewhere in PlanetGIS) is determined by your
operating system setings (Control Panel→Clock,
Language & Region). $coordinate corresponds to
the centre point of your map.

Floating legend
A foating legend is a common addition to a map.
Te font size should be “auto” for most cases and
use the “multi-column” option together with
options in the “Legend” tab of the properties of displays (Displays tab→Right-
click→Properties→Legend) to control the layout and visibility of items in the legend.

Floating locality map
A locality map provides locational context. Te default location is top-lef and ofset by 5mm. No 
frame is used by default.

Options for a locality map are:

• Scale factor: scale of locality map = scale of map x factor

• Choose another view: locality maps must be less complex as in this 
example of the World map that uses the Economy view for the 
locality map.

• Use a saved location for user-specifed locality.

• Whether and how much to darken the area outside of the visible 
map area.
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Figure 28: Specifc properties for a legend

Figure 29: A locality map



Callouts
Callouts are elements added to a map that are 
“tethered” to a coordinate. Callouts are used to 
draw atention to a location or feature and atach 
content to it. Te most common type of callout is a
“speech bubble” containing text. Callouts can have 
most of the content types as foating objects. Only 
the properties for positioning are diferent.

When sizing frames are enabled you can move the 
anchor point and the callout independently. Te 
relative distance between the callout and anchor 

will be maintained and the callout will only be displayed if the anchor point is visible on the map.

Printing & Reporting

Printing
To print the map displayed on your screen, it is advisable to frst activate Print previef in the 

menu toolbar ( ). If you skip this step Planet will do it for you, but the print job will also start. 

Print preview shows you what the printed map would look like for the paper size currently selected 
for your printer at the same scale as on your screen when not in Print preview. Te “page” is scaled 
to ft onto your screen, so will probably look smaller than the hard copy that will be produced1. In 
Print preview mode, the scale displayed at the botom of the screen is not the displayed scale but the 
hard-copy scale, so you have to keep in mind that the map is (probably) smaller due to additional 
scaling to ft the page onto the screen.

Print preview shows the selected paper orientation and the printable area. Printers report to the 
operating system exactly how many millimetres from each of the four edges of the paper they are 
able to print2. You can drag each margin to increase the size of the edge, or specify exact values if 
you create a “page frame” (see below).

To select a printer and to change the page size, click File→Print setup.

Paperless printing (eg. PDF)
It is a common task to create PDF (Adobe Acrobat Portable Document Format) fles of maps. Planet 
cannot create PDFs directly, but there are many “PDF creators” that can be installed. Bullzip is a 
popular example (htp://www.bullzip.com/products/pdf/info.php). Tese, when installed, look like a 
regular printer and when you print, a PDF fle is produced. PDF has one drawback in that it doesn't 
support transparency (Planet's transparent flls appear black).

A litle known alternative to PDF that works well for anyone using Windows, is Microsof's XPS 
Document Writer. (XPS stands for XML Paper Specifcation). Apparently meant to be an open and 
popular alternative to PDF, it is unclear if this format will ever become as widespread in use. You can
create an XPS document on any version of Windows since Vista (unless you uninstalled the XPS 
printer) and any other user of Windows can view and print it3. XPS integrates beter with printer 
drivers (on Windows) and handles Planet's transparent flls very well. If you have a map in an XPS 

1 Tese days, with large screens and high resolutions, what you see on screen is very similar to what you will see on an 
A4 page. Try a larger format like A2 or A0 to see a marked diference.

2 PDF & XPS (among a few physical printers) can print right up to each edge.
3 Of course, for users of Mac and Linux systems, PDF is still preferred.
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Figure 30: An "arrow tethered" callout
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document, you can still produce a PDF from the XPS viewer which is included in your Windows 
installation by printing it to a PDF creator.

Reporting
Te easiest way to include maps into your own documents is to copy the contents of the screen to 
the clipboard and paste it into your word processor (or other sofware). Te copy-to-clipboard 
function is not under the Edit menu, as is traditional, but rather under File, then 
Clipboard→Copy bitmap. Depending on the
sofware and the content of your map, Copy
metafle might work beter because it is a vector
format that should yield beter quality when
printing. You need to experiment with it to see
which works beter for you.

When copying a bitmap or metafle to the
clipboard, a setings window appears, allowing you
to specify the image resolution (see Figure 31).

You have the option to change the physical size in
pixels or the resolution (as density in pixels per
inch or dpi). While you can change the actual size
to infuence the resolution, it is not as useful. For
example, a typical computer screen has a dpi of around 100. An image of 100 dpi, however, will not 
look as sharp when printed because a typical printer can produce images at 300, 600 or higher dpi. 
To create an image for including in a document that will be printed, the easiest is to change the 
resolution to 300 dpi4.

It is also important to note the diference in initial setings when you are in print preview mode as 
opposed to normal viewing. In print preview, you will get the size and resolution for the currently 
selected printer which will produce an image that will take a lot of storage space inside your 
document.

Finally, you can also save images to fle from where you can manipulate them with image editing 
sofware and include into documents at a later stage. File→Save imagee Tis option gives you 
more control over the fle format. For lossless compression (image remains exactly like the original), 
PNG is the best option. If a slight reduction in image quality is acceptable, JPEG is a good option5. 
Afer selecting the image fle format and entering a fle name, a setings window similar to Figure 31 
will appear with additional options related to the fle format.

Print Frames
Te fnishing touch for printed maps ofen include a frame (border) around the map. Tis can be set 
up and selected similar to foating objects. Frames can also be created inside frames, so you can 
create a hierarchy of frames in order to add a title block, for example. Te possible types of content 
of each frame (other than more frames) are similar to foating objects.

4 Even on a 600dpi or higher printer, 300 tends to be enough and also saves 75% in storage space as compared to 600dpi.
5 You can control how much the image quality is degraded: 90 would be almost imperceptible, while 60 will yield 

excellent compression.
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Creating & selecting a print frame

To work with print frames, you need to activate Print previef in the menu toolbar ( ). To select 

and edit print frames, use the “map popup menu” (long-right-click, i.e. keep the right mouse buton 
down for ½ second on your map. In
print preview mode, unless your click
mode is “Zoom”, a regular quick right-
click does the same). Now follow the
following steps:

1. Click Print frames and 
Selecte

2. Click Nef if creating a new
print frame, otherwise Select.

3. Give the print frame a name
for easy reference. Typically
the paper size and orientation
is used as part of the name.

4. Click Edit to start seting up
the frame.

Seting up a simple page frame
A page frame ofen consists of more frames inside it. Te
default content for a page frame is therefore “Frames”. Te
simplest type of page frame, however, contains the map at
the top level. Te content of such a frame must therefore be
set to “Primary map”. When seting up print frames, one
frame must have a primary map, or no map will be
displayed.

Alignment
Frames can be aligned to an edge of the page. An alignment
of “All” means to use all space available to the frame. An
alignment of “None” allows exact placement of a frame. Care must be taken with a “None” alignment
as such a frame can overlap and obscure other frames. An aligned frame (other than “All”) requires a
size to be specifed in the “Outer spacing” tab. All measurements use the same units as specifed in 
the “General” tab.

Outer spacing
Outer spacing defnes the outermost measurement of a frame. For lef/right aligned frames a width is
required (but height is ignored, if specifed). For top/botom aligned frames a height is required (but 
width is ignored, if specifed). For a page frame (outermost frame) the ofsets are the distances to the 
edges of the page. Ofsets should be used with care for any inner frame as inner spacing normally 
provides beter control.

Border
For a typical page (outermost) frame, a thin-and-thick border is typically used. Use “All sides” to 
select the same line style for all edges. Te exact widths of lines, spacing and colour can also be 
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Figure 32: Creating a print frame

Figure 33: Creating a simple page frame



changed in this tab.

Inner spacing
Inner spacing is the margin between the content of a frame and its innermost border. In most cases 
this should be 0 for frames containing more frames and at least 1mm for frames containing actual 
content, e.g. text.

To create a simple page frame for your map, you only need to specify “Primary map” as the content 
and choose a line style in the “Border” tab.  Ten click OK and Close. If you have created the frame 
earlier you also need to click Select.

Seting up more complex frames
Editing and expanding on your print frames will require a series of Map menu → Print frames →
Edite (don't click select unless you want to pick another
print frame for your map, although you can simply click
the Edit buton to work with the selected frame). 

More complex frames require frames-within-frames. In
order to create frames inside your page frame, you will
have to change the content from “Primary map” to
“Frames” (See Figure 34).

Click Edit, change the content to “Frames” and click OK.
(You will notice your map disappear in the background).

Now, instead of Edit, click Add and then Inside 
selected frame. (See Figure 35).

On this level you will need at least two frames: one for frame content and one for your map. Figure 
64 shows a print frame with an empty title block (right-aligned, 50mm wide, single border on lef) 
and a frame for the map (alignment All).

From here you can add multiple top- and botom-aligned
frames inside the title block for a legend, title, project
description, scale bar and company logo. Choose one frame
to be All-aligned, so that it would make use of remaining
space lef over from the other frames. When multiple frames
have the same alignment (eg. Top), the creation order
determines the actual layout order. You can change the order
in Design Mode (see next section).

Seting up print frames requires a lot of work and careful planning. You cannot use the mouse to 
resize the frames and must instead supply exact widths, heights and margins. Tis pays of in the 
long run as you can always reuse your frames in other projects and you have full control over the 
layout. You can also create a duplicate set of frames from an existing set in order to make minor 
adjustments (e.g. to create a print frame for an A3 page from one created for an A4 page). For 
complete control over your print frames, locate them in Design Mode (next section). 
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Figure 34: Changing the page frame to allow inside frames

Figure 35: Adding frames inside frames

Figure 36: Print frames with the beginnings of a title 
block



Notes
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Chapter 5

CREATING YOUR OWN PROJECTS



Starting a New Project
To start a new PlanetGIS project, select “Create a new Planet project” in the Qick start window or 
select File→Nefe

Afer you have specifed a location and name for your project, Planet needs a coordinate system to 
be specifed. 

Te most common coordinate system in use today is WGS84, a geographic projection using 
spherical latitude and longitude coordinates. Tis is also the default coordinate system used by all 
GPS devices. In South Africa, we use Hartebeesthoek94 which is equivalent to WGS84 for most 
purposes. You can select either of these for projects in South Africa that will not be using a local 
coordinate system.

If “All” is selected under “Area of use” you can click on the list of coordinate systems and type “har” 
or you can select “World” as the area of use which will produce a short list containing WGS84. You 
can also explore by expanding “Africa” and selecting “South Africa”.

If you do not select a coordinate system (press Cancel), your project will use a “non-earth” 
projection which is a simple, fat, Cartesian coordinate system. Transformation to/from (data 
exchange with) any other “earth” coordinate system will not be possible.

Multi-map Projects
PlanetGIS can combine data from multiple maps (projects). Tis is very useful for adding “backdrop” 
information to your new project. For example, most projects could beneft from displaying 
administrative boundaries to provide context. You can open any number of additional maps without 
closing any. You can then use the Windof menu item to switch between them. Design mode will 
show all the maps that are open including secondary maps which will not be displayed in the 
Windof menu. To view secondary maps, you have to activate them in Design mode (double-click 
on the project node or right-click and click Activate).
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Figure 37: Selecting a coordinate system for a new project



In addition to the Windof menu, the Map popup menu (right-click for 0.5s - a so-called “long-
right-click” - on the map) provides a function to go to the same location on another map. See Figure 
38.

In multi-map projects, we will use the terms “external maps/projects” or “secondary maps/projects”. 
An external project is simply another project that is opened at the same time as the project which is 
the focus of your current task.  External projects are available to add as displays into your main 
project (i.e. your current focus). A secondary project is a project that has become a dependency of 
another project. In other words, some other project included one or more feature classes as a display
and is now dependant on it. Secondary projects are opened automatically by the projects that 
require them. If a secondary project cannot be found, Planet will ask you to locate it. You can choose
to ignore (click “No”) and the main project will open without it, ignoring displays that reference 
feature classes from it.

If you have multi-map projects which also need to be portable (i.e. able to be run from an external 
storage device) it is important to keep them all in a directory structure where relative paths can be 
maintained between them. Projects on diferent drives are not portable if they are part of a multi-
map setup.

You can use the “SA administrative boundaries” map (available here: 
htp://www.planetgis.co.za/browsemap.php?id=13) for the examples below.

Adding external feature classes in the Display Manager

1. Activate the Display tab and click on “Click to add” or anywhere in the white-space below 
existing displays.
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Figure 39: Adding external feature classes

Figure 38: Zoom to same location in another map
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2. Expand the external project “SA-administrative.map”.

3. Click on the frst feature class you would like to add.

4. Press <Shift> and click on the last feature class (alternatively select [or unselect] individual 
feature classes by pressing <Ctrl> while clicking).

5. Press <Enter> to select (or click the “Select” buton).

Feature classes with thematic queries
You will notice that the “Towns” feature class that you've
selected is not ideal for mapping purposes. A feature class
like this needs to be classifed into a hierarchy and set up
such that only the more important features are displayed
at smaller scales (zoomed out more).

Figure 40 shows that you can expand the node for the
feature class “Towns” and select a thematic query named
“Towns (levels)”. You could have done this in the previous
step: selecting multiple feature classes with <Ctrl> allows
you to expand nodes without clearing the selection. Te
steps for selecting a thematic classifcation for towns
instead are as follows:

1. Hide the “Towns” display by clicking on the eye icon, or delete it by choosing the delete 
option from the popup menu (right-click on the display).

2. Click on “Click to add” or right-click anywhere in the Display manager and select “Adds”.

3. Expand the SA-administrative project and then expand “Towns” by clicking on the triangle 
icon.

4. Select “Towns (levels)”.

Renaming displays
Displays are automatically assigned the names of the feature classes (or thematic queries) they are 
referencing. Within the context of a view, it ofen makes sense to rename a display to something 
more appropriate. A single click on the name of a display will place the node into edit mode, 
allowing you to rename it. Alternatively right-click and choose “Propertiess” where you can change 
the name among many other properties.

In this particular case, you might want to rename “Towns (levels)” to simply
“Towns” or even “Places”.

Grouping displays
Te Display Manager can very quickly become hard to manage due to too
many displays. When layers can be logically grouped together (and especially
with “backdrop” type information), it is always a good idea to create a group
display frst. 

1. Right-click in the Display manager and click “Create group”.

2. Type in a name for the group, e.g. “Boundaries”
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Figure 40: Selecting a thematic query

Figure 41: Creating a display 
group



3. Drag-and-drop each display into the group, making sure you drop on top of the text, i.e. 
“Boundaries”. Start with the topmost display (“District Municipalities”) if you want to keep 
the order.

A more efcient procedure would be to create the group before 
adding the feature classes. You can right-click on the group display 
and then click “Adds” to create displays for the selected feature 
classes inside the group. (See Figure 42).

Now that you have a group of related displays you can easily switch 
of the displaying of the whole group by clicking on the group's eye 
icon. Te whole group can also be dragged to a diferent position in 
the list. 

Te above examples are the most typical uses of the Display manager.
Tere is, however, a more efcient way to set up the displays of a 
view from multiple secondary maps: Design Mode.

Using Design Mode to set up your Views
A more efcient method of adding displays into a view, is to copy the displays from another project 
to your main project. Displays are references to feature classes and contain many options and 
setings. By copying a display, you will retain all those setings. By adding a feature class into a view,
you create a new display which references the feature class and also the feature class' default style. 
Terefore, if you are seting up your own projects to utilize displays from external sources, (and 
assuming you want to preserve the general appearance and behaviour) you would save time by 
copying displays from the source project to your main project.

For the following examples you can use one or more of the provincial
cadastral maps as well as the OpenStreetMap, or one of the projects that
combine these. All the South African maps can be downloaded from this
page: htp://www.planetgis.co.za/browse.php?id=11

1. Activate Design Mode.

2. Expand the nodes of your project so that the displays of the frst
view are visible (Figure 43).

3. Right-click on the view node (“My project”, if that is what you
named your project).

4. Click “New”, then “Group” (Figure 44).

5. Enter “Cadastral” as the name for the group.

6. Now expand a cadastral map and click on its
frst view. You must be able to see the displays
of the view on the right-hand side.

7. Click on the frst display on the right-hand pane
(“Parent farms”), then press <Shift> and click
on the last display you want to use (“Parks” is a good choice). (Figure 45).
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Figure 42: Adding feature classes 
into a group

Figure 43: Expanding a view to see its 
displays

Figure 44: Creating a display group in Design mode
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8. Use the scrollbar to make your target visible in the lef-hand pane. Your target is the group 
display you have created (“Cadastral”). (Figure 45).

9. Now drag your selected displays from the right and drop it exactly onto the text of your 
target node (i.e. “Cadastral”). Also shown on Figure 45.

You can also use Design mode to copy displays from one view to another in the same project, delete 
multiple views, move displays into a group, reorder displays, etc.

Copying displays vs. copying feature classes
It is important to be aware whether your source and target is a display or a feature class, since they 
may look the same (same styles). A display is a reference to a feature class. If the source is a display 
and you are copying into a target vief, you copy a reference along with all the setings of the 
source display. 

You can drag a feature class (or selection of feature classes) into a view of the same or another map. 
Tis will simply create a display referencing the source feature class. (Te display will not have any 
custom setings, since it is new).

If you drag a feature class to the “Feature classes” node of another map (or into a feature class 
group), a copy of the feature class with all its features and atributes will be made. In this case you 
will have created a duplicate of the database and you will still need to create displays (drag them to a
view) to see them in the destination map.

Styles (and everything else)
Styles will usually be copied across automatically, but you can always drag a style to another 
project's “Styles” node. You can also drop a style onto a feature class or a display to assign the style 
to the feature class or display. If the style is from a diferent project, a copy will automatically be 
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Figure 45: Dragging displays from one project to another



made in the destination map and the reference will be to the new copy.

You can also copy style elements (e.g. a pen) to other styles.

Print frames, foating objects and saved locations can also be copied between projects in this way. It 
will serve you well to have a project containing templates of your styles and print frames that you 
can call up and copy anything you need to a new project.

Notes
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Chapter 6

COORDINATE SYSTEMS



World Geodetic System 1984
WGS84 is the coordinate system used most commonly on Earth. It defnes an “ellipsoidal” model that
closely approximates the shape of the earth1. Te origin point of this system is the centre of Earth's 
mass, determined by observations from outer space to an accuracy believed to be less than 2cm.

WGS84 is a spherical coordinate system which uses angular units, latitude and longitude. It is 
important to realise that the distance between two points on the surface of the Earth is expressed as 
an angle between the two points and the centre of the Earth. Te actual radius of the Earth 
determines the exact distance between the points and will change if a diferent ellipsoidal model is 
used. A latitude or longitude is simply the angle of some point on the surface, the middle of the 
Earth and the zero line of latitude (the Equator) or the zero line of longitude (the Greenwich 
Meridian).

Te WGS84 ellipsoidal model has a major (equatorial) radius of 603780137m and a minor (polar) radius
of 603560752m. An ellipsoidal model does not take into account mountains or even mean sea level at 
any particular location. Te model is a smooth surface which is the mean sea level for the whole 
planet. Mean sea level at specifc locations can be up to 105m below the ellipsoid (South-East India) 
and up to 87m above (eastern Indonesia). Tis is due to gravitational changes which is due to 
irregularities in the composition of the inner Earth.

Coordinate systems and projections
Maps on computer screens and paper are fat representations of a surface which is not fat. Te 
transformation from a spherical surface to a fat surface is called a “projection”. If you look at the 
World map, it is obvious that the closer to the poles you get, the more the shapes and sizes of land 
masses are distorted. Tis is because the projection used keeps lines of longitude straight and 
parallel. It is common for a world map to use a diferent projection where lines of longitude are 
curved, but not so much on computers. 

If you zoom in a bit you will see that Planet adjusts the distance between lines of longitude 
(meridians) so that shapes of landmasses
(or borders of countries and other
features) in the middle of the screen
correspond beter with reality. Only a thin
pixel-wide horizontal line running
through the centre of the map is exactly
correct. Everything North and South of
this line must necessarily be distorted to
keep meridians parallel to each other. Te
more you zoom in, the more accurate
features will be refected, similar to how
the Earth seem fater the closer you are to
the surface.

In 1569, Gerardus Mercator, a Flemish
cartographer, presented a projection to
solve this problem for nautical navigation.
His solution was to stretch out the distances between lines of latitude (parallels) the closer they get 

1 Te shape of the earth is an “oblate spheroid” - a sphere with a slight bulge at the equator due to the centrifugal force 
due to rotation.
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Figure 46: Te famous Mercator projection



to the poles. Te shapes of landmasses are distorted similarly, but this projection became the 
standard for nautical navigation because lines of constant course become straight lines. 

Other methods of projection are also used, especially
when working with smaller areas than the World map.
Te most common projection is to use a cylinder that
touches the surface of the sphere along a line of
longitude (meridian). Tis is then fatened into a system
with X and Y coordinates. Te fatening of the cylinder
creates a distortion which only becomes noticeable
about a degree away from the central meridian. Tis
type of projection is called Transverse Mercator2 and
is appropriate for areas no wider than 6 degrees
(preferably less than 3 degrees). Projections like this are
used in local coordinate systems.

Te projection onto screen of spherical coordinates is a simple on-the-fy transformation. Te 
coordinate system remains spherical, so it is called a “geographic coordinate system”. 

When the coordinate system is a projection onto a fat surface with X and Y values (usually in 
metres) it is called a “projected coordinate system”. Since the coordinate system is on a fat surface,  
there is no transformation needed when displaying on a screen or paper. Te X and Y values in a 
projected coordinate system are typically the distances from the equator and a chosen central 
meridian.

Local coordinate systems
In South Africa there is a Transverse Mercator coordinate system centred around every odd-
numbered meridian. Tey are called “Lo” (el-oh) systems. You can see in Figure 37 (previous chapter)
that the “Hartebeesthoek94 / Lo” systems range from 15 degrees longitude to 33 degrees, spanning 
the breadth of SA. A shorter form of the name “Hartebeesthoek94 / Lo XX” (where XX denotes the 
longitude value of the central meridian) is simply “WGXX”. 

It is becoming more common to simply use a geographic coordinate system, but if your project 
requires the use of an Lo system, you need to choose the system with the central meridian (the 
number afer “Lo”) that runs through your area. If there are two, choose the one closest to the centre 
of your area. Sometimes it is impossible to “spill over” into a neighbouring zone. Tis is OK, it will 
be nearly impossible to notice the distortion until you get into the next neighbouring zone.

Features can also be copied between zones with no loss of information (see below).

Outside of South Africa – especially in other African countries – the coordinate system used is 
Universal Transverse Mercator (UTM). Tis is a system developed by the United States Army 
Corps of Engineers that divides the earth up into zones that are 6 degrees wide. Distortion is 
balanced out by using a scale factor which creates two lines of “true scale” parallel to the central 
meridian. Te South African Lo systems do not use a scale factor (actually it is simply 1) and 
therefore the only line of true scale is the central meridian and that is also the reason why Lo 
“bands” are only two degrees wide.

2 Other names in use are Gauss-Krüger or Gauss conformal projection.

Coordinate Systems 50

Figure 47: Cylindrical projection of the sphere



South facing coordinate systems
Rather unique in the world, South Africa has “south facing” local coordinate systems. Lesotho, 
Swaziland, Namibia and Zimbabwe shares this oddity, while Botswana uses UTM like most other 
African countries.

Contrary to what a mathematician would expect, the convention in Lo systems is that X is the 
distance from the Equator toward the South Pole and Y is the distance fest of the chosen central 
meridian3. Even more confusing is that the convention is to write Y frst, which make the 
coordinates appear like X,Y except that the signs are wrong. It is easy enough to convert Lo Y,X to 
Cartesian coordinates:

X' = -Y
Y' = -X

Also important to know is that directions are south facing: 0 degrees is South; 90 degrees is West.

All sofware that hasn't been specifcally designed for South Africa will store coordinates in 
Cartesian format internally. Some (like Planet) will display the coordinates in the expected 
convention. Shapefles always come in Cartesian X,Y. DXF can be either. If you receive Lo 
coordinates in a text fle (typically from a survey diagram) it is most likely Lo Y,X. If you receive 
coordinates in a database table it can be either.

Fortunately, since South Africa is far from the equator, the X value is always larger than 200000000 
which helps identifying which is which, however, it is not uncommon – especially in CAD drawings
– for the 2 000 000 to be subtracted to reduce the length of the numbers. Tis is called a “false 
northing”.

Datums in South Africa
In the simplest sense, a “geodetic datum” defnes the location of the centre of the earth and the size 
(major and minor radius) of an ellipsoidal model of the earth. Geodetic datums usually have a fxed 
point defned somewhere on the surface of the earth to account for continental drif.

Hartebeesthoek94 is the ofcial South African datum and uses the same centre point and dimensions
as WGS84, so a coordinate in a system based on either datum will be the same4.

Before WGS84, a diferent estimation of the size and centre of the Earth was used. Te South African
coordinate systems were initially set up based on the size of the Earth as described in a book named 
“Geodesy” writen by Col. Alexander Ross Clarke and published in 1880. He described the “fgure of 
the Earth” with a major radius of 603780249m, only 112m more than our current model for which we 
needed to get into space! Tis model of the Earth is called the “Clarke 1880 ellipsoid”5. Te original 
South African datum was called the “Cape Datum” and has its fxed point at Bufelsfontein, near Port
Elizabeth.

Gravity measurements from space allowed us to accurately determine the centre of Earth's mass to 
within 2cm. Te diference between the centre points of WGS84 and Cape (Clarke 1880 ellipsoid) is 
surprisingly small too: 292m north, 110m east and 134m along the axis from the centre of the Earth 
to 0, 0 on the surface (a point at sea about 500km South of the coast of Ghana).

3 Every other system in the world using X,Y coordinates follow the Cartesian convention: X-axis points East and Y-axis 
points North.

4 Well, nearly. WGS84 actually gets recalculated periodically. At the moment Hartebeesthoek94 coordinates are between
20 and 30cm away from WGS84. Continental drif will also have an impact because the Hartebeesthoek94 datum has a 
fxed point at the Hartebeesthoek Radio Astronomy Observatory Telescope near Pretoria.

5 Ofen called “Modifed Clarke 1880” since Clarke calculated a diferent fgure in 1866 (~43m smaller).
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Maps produced in South Africa before 1999 mostly used the Cape Datum and from 1999 onward 
maps were using Hartebeesthoek94 and older data converted to the new datum. It is becoming 
increasingly rare to fnd maps in the Cape Datum, but if you have such data, it is important to know 
the diference and the procedure for converting the data.

When data sources are mixed and you have features of both the Cape and Hartebeesthoek94 datums,
there will be an ofset of roughly 300m north-east in a projected coordinate system. In a geographic 
coordinate system the diference is much less because the angular (spherical) coordinates assume the
same Earth radius (whichever datum is selected for your map). Te diference varies slightly 
throughout South Africa from around 5m to 15m.

Changing coordinate systems
If you know that a map is in the Cape datum, either Cape geographic or Cape Lo projected, it is a 
simple action to tell Planet about it: Click File→Project→Coordinate system to open the 
coordinate system window. 

To tell Planet what coordinate system a project is currently in click the Select buton. To convert a 
project to a diferent coordinate system, frst verify that the information about the current system is 
correct (and click Select if it isn't), then click the Convert buton to select a new coordinate system 
and reproject all features in the project to the new system. For multi-map projects this need to be 
done for each individual map. An alternative to the File→Project→Coordinate system menu is 
to right-click on the project in Design mode and then click Coordinate system.

If you are copying features between two maps with diferent coordinate systems, the features will be
automatically reprojected provided the coordinate systems have been correctly defned in both 
maps.

When working with diferent coordinate systems, you may want to maintain a Planet project for 
each system and periodically copy features between then (typically from the older to the newer 
system). Tat way it is easy to update features in the old system from sources that remain in the old 
system. (See Importing below).

Other projections
Tere are many other projections designed for small scale mapping (continents / subcontinents). 
Tese are primarily conical projections which model the curvature of the earth by a conic volume 
that bisects the sphere at two lines (usually) of latitude (also called “standard parallels”). 

Te two most common projections are “Albers Equal Area” and “Lambert Conformal”. Te former 
preserves area but distorts direction and distance, while the later preserves direction and angles but 
distorts area and distance. If you encounter source data in either of these projections, you will need 
to supply all the parameters for the projection exactly as the source of the data has determined them.
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Secondary (projected) coordinate system
For projects in a geographic coordinate system, Planet can also be set up with a second, projected 
coordinate system.

Figure 48 shows a geographic
coordinate system set up with an
additional projected coordinate
system. Tis is very useful for
importing or exporting features
and for coordinate display on your
map.

Map coordinate display
Te coordinate system for the active project is shown
next to the scale and mouse cursor coordinates (Figure 
49).

To change the coordinate display format, click directly on the
coordinate text. Along with other formats for spherical coordinates,
you will also see an option to display projected coordinates (if a
project system was set up as in the previous section).

If you select “Y; X” as in Figure 50, you will see that the coordinate system text changes to 
“Hartebeesthoek94 / Lo27*”. Te asterisk at the end indicates that it is not the actual coordinate 
system of your project.

Mixing coordinate systems
Planet will allow you to create a multi-map project containing diferent coordinate systems. Te 
coordinate system that Planet will use is the one set up for the active map. Features from secondary 
maps will not be reprojected on-the-fy and features from secondary maps will not be in the correct 
position6.

6 In future, on-the-fy reprojection may be implemented.
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Figure 48: Coordinate system window with secondary coordinate system selected

Figure 49: Scale, mouse coordinates and coordinate system 
display

Figure 50: Select coordinate display format



Considerations when importing or exporting features

Importing
Before importing data that has projected (X,Y) coordinates, you need to set up the coordinate system
to match the source exactly. Shapefles normally come with a *.prj fle which describes the source 
coordinate system. You can open this fle with Notepad. It is a bit hard to decipher since all the 
information is in one line, but it is possible.

If you have a project already in a projected (X,Y) system but are importing geographic (/spherical lat 
& long) coordinates, you don't need to do anything. Every projected coordinate system knows how 
to convert spherical coordinates to local coordinates and back. Except, if the datums are diferent, 
e.g. if the spherical coordinates are from a Cape datum but your project is in Hartebeesthoek94 or 
WGS84. For this scenario follow the same steps for reprojecting explained above.

Exporting
Te issue of producing X,Y coordinates from lat,long coordinates comes up most ofen when 
exporting to DXF. Tis is because DXF is used to get GIS data into CAD applications, which nearly 
always need a fat, projected coordinate system. PlanetGIS therefore provides this reprojection as an 
option in the DXF export options window (which simply sets up a secondary coordinate system as 
shown above).

In all other cases you need to reproject your data before exporting. Te procedure is as follows:

1. Create a new project with the desired coordinate system

2. Copy the data from the source project to the new project

3. Export the data from the new project.

Te copy process will automatically reproject coordinates. Tere are two ways to copy data between 
projects:

1. For a selection of features on the map, use Edit→Copy

2. Drag-and-drop feature classes between projects in Design Mode
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Chapter 7

CAPTURING FEATURES



Creating a New Feature Class
Although called “feature classes” new feature classes are actually “feature subclasses”. At the top 
level, a feature class is a subclass of the root feature class. Te root feature class contains all 
atributes that are applicable to all features in any feature class, including the feature's location and 
geometry.

When creating many feature classes, consider whether a feature class is beter defned as a subclass 
of another feature class already in your project. For example, an asset management system for a 
municipality may have at the highest level “Electricity”, “Water”, “Sewer”, “Stormwater”, “Roads”, 
etc.

When adding atributes, consider at which level an atribute will be most appropriate. Which feature
subclasses will share the atribute?

Allowed feature types
When creating a new feature class, you must specify which
feature types will be allowed. In the vast majority of cases, it
is best to choose only one type to avoid future confusion and
complications with styles and capturing. It can be very
useful, though, to allow multiple types as can be seen in the
OpenStreetMap project.

You can also specify no types to force features to be captured into subclasses instead. Te feature 
class will act as a “group” in this case.

Although possible, it is not recommended to mix raster with any other type.

Capturing Points

Figure 52: Capturing a point into a new feature class

To capture a point on your map, into a new feature class, follow these steps:

1. Click Edit→Capture (or <Ctrl+N>)
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Figure 51: Creating a new feature class



2. Click Nef, then Feature classe  (or select a feature class in the tree and click Nef, then 
Feature subclasse)

3. Enter a unique name (among other subclasses of the same parent class, if any)

4. Check Points

5. Click Create

6. Click Select

7. Click on the map

You will notice that the “click mode” has automatically changed to “Capture point”.

If you know the coordinate for the point that you
want to capture, right-click instead of lef-clicking on
the map to enter the coordinate by hand.

Planet understands coordinates in various formats:

• Degrees:minutes:seconds (27:30:00.0)

• Degrees° minutes' seconds” (27° 30' 0.0”)

• Degrees:minutes (27:30.0)

• Degrees° minutes' (27° 30.0')

• Decimal degrees (27.5)

“S” at the end is a substitute for negative latitude (don't do -27.5 S) and similarly “W” at the end is a 
substitute for negative longitude. “E” and “N” are entirely optional.

To capture multiple points, keep clicking on the map. Each new point will be a separate feature with 
a new FeatureId.

Moving points

To move a point, you have to change the capture mode. Click on the “Capture point” buton ( ) 

and hold the lef mouse buton down for ½ second (long click). Ten click the “Edit vertex” buton (

). When moving points, you have to be extra careful not to inadvertently move a coordinate of a 

feature (eg. an administrative boundary or orthophoto). It is best to click on the point (leting go of 
the mouse buton) and then to verify that you have the desired point selected. Te Info, Selection 
and Edit tabs on the right can be used to monitor your selection.

You will now see a small black square on top of the point feature. Now click, hold and drag the point
to the desired location and let go of the mouse buton.

Deleting points
To delete any feature that is not desired, verify you have that particular feature selected (Info, Select 
or Edit tab on the right) and only that feature selected (unless you are deleting multiple features), 
then click Edit→Delete in the main menu.
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Figure 53: Entering a coordinate by hand



At this point you would probably want to select a new
style for the points which currently have the default
small white dot (if you haven't changed your default
style). Follow these steps:

1. Activate the display manager by clicking on the tab.

2. Select the “Points” display and right-click on it to
see the popup menu.

3. Click Select stylee

4. Click Nefe, then Stylee

5. Enter a name for the style.

6. Click Adde, then Symbole

7. Click on the Shape buton.

8. Expand the “WSP” node.

9. Select “Industrial” (feel free to deviate here)

10. Select a shape.

11. Click OK

12. Change the width to 10mm and click OK.

13. Now click on Adde and Fonte

14. Change the font setings or leave as is.

15. Click OK and again OK and fnally Select.
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Figure 55: Selecting a shape for a symbol

Figure 54: Creating and selecting a new style



To conclude this exercise, we will label the captured points.

16. Change the click mode to Tag.

17. Select a point by clicking on it.

18. Activate the Info tab.

19. Enter a label for the point, e.g. “Tower 1”.

20. Save the change by clicking on the Save buton or pressing <Enter>.

21. Select the next point.

22. Enter another label and Save.

Capturing Lines
Repeat the steps above to capture and create a new feature class which allows lines1 instead of 
points (Edit→Capture→Nef feature classe). Notice that the click mode has changed to 
“Capture” automatically. You can activate the Edit tab on the right for variation.

Now follow these steps:

1. Click somewhere away from the points to capture the frst coordinate of a line.

2. Move the mouse cursor close to the centre of one of the points. Notice how the location “snaps” 
to the point when the mouse is close enough. Move the mouse around a bit to see the 
“snapping” at work similar to a sticky spot.

3. Click to capture the second coordinate exactly at the centre of the point.

4. Repeat for second point. In a GIS it is very important to capture coordinates that are supposed 
to be coincident with other coordinates so that they are exactly coincident.

5. Move the mouse away and right-click.

6. Select End. (A quicker way if you don't want to see the menu is to press <Enter>).

1 Strictly speaking, a line could be a line segment (exactly two vertices/coordinates) or a polyline (many 
vertices/coordinates). In PlanetGIS we use the term “line” as a shortening for “polyline”.
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Figure 56: Labelling points



Note that if you wanted to retain the coordinate at (5) you would have to have frst lef-clicked to 
capture the coordinate.

To remove the last captured coordinate, right-click and click Undo. To cancel capturing the feature, 
right-click and click Cancel or press <Esc>.

Lines with breaks
Lines may have multiple parts, i.e. lines can have  “gaps”. To end a line part, right-click and click 
Break. Click again to start the next part of the line.

Using distance and direction to determine subsequent coordinates
Qite ofen, the relative distance and direction between coordinates
is known instead of the coordinates themselves. Right-click while
capturing and click Enter direction/length.

It is sometimes useful to move the mouse in the general direction of
the anticipated next coordinate. Te current distance and direction
will be displayed in the window, which can then be rounded or made
accurate.

Snap options
Snap options control the exact position of a captured coordinate which may be
up to a certain amount op pixels away from the mouse cursor location. Tis is
called “Snap sensitivity”.

When capturing features by tracing them on an underlying orthophoto, one
ofen doesn't want to have other features interfere with the capturing, i.e. you
might want to turn snapping of. In other instances you may want to snap to
points (vertices/coordinates) but not the line segments connecting them.
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Figure 58: Capturing by specifying distance 
and direction

Figure 59: Snap options

Figure 57: Capturing a line



Capturing Polygons
Polygons are similar to lines except that they are always closed. Polygons can have multiple “outer 
rings” and each outer ring may have any number of “interior rings” which form holes or islands. 
Click Break in the capture menu to start a new ring. If you are capturing a hole, be sure to reverse 
the direction, i.e. if the outer ring was captured clockwise, capture all holes/islands counter-
clockwise.

Polygon orientation
PlanetGIS allows polygons in any orientation, but the standard in GIS is to have outer rings in 
counter-clockwise order and inner rings in clockwise order. An observer walking around a polygon 
in the same order of the coordinates will have “surface” / fll on the lef hand side and either nothing 
or hole / island on the right hand side. It is a good habit to be consistent with this convention.

Capturing rectangles or shapes with right angles
Planet is ofen used to capture the footprint of buildings (or “roofops”). To speed up the process 
Planet has two very useful functions.

1. Complete rectangle. Capture one side and position the mouse over the next corner, then 
right-click and select “Complete rectangle”. Don't lef-click on the third corner because the 
angle will not be guaranteed to be 90 degrees unless you use the following. Te mouse 
position tells Planet the length of the second edge and Planet will place the third corner so 
that interior angles are 90 degrees.

2. Snap to right angle. Tis snap option will steer a captured coordinate to a location which 
will form a right angle with the previous segment. You may want to increase the snap 
sensitivity for this.

Capturing circles
To capture a circle, start by indicating the centre point and move the mouse to the edge of the circle, 
but don't lef-click. Now right-click  and click “Draw circles”. Te radius as indicated by the mouse 
and central coordinate will be displayed in the Draf circle window. You can supply an exact radius 
and change the central coordinate. Te circle will be approximated by many line segments. Te 
default number of segments (“steps”) is 32. Click OK to fnish capturing a circle.

Capturing Raster Images
“Raster” means a matrix or grid of values or colours. Raster images in GIS are typically satellite or 
aerial photographs, but could also be scanned drawings or maps. Most raster images will already be 
“georeferenced” meaning the location on earth is known, but they need to be captured in Planet 
similar to other types of features.

Planet supports the following types of images directly:

• MrSID (*.sid)

• Enhanced Compressed Wavelets (*.ecw)

and will create compressed and indexed images (*.ijp) from:

• Windows Bitmaps (*.bmp)

• JPEGs (*.jpg, *.jpeg)

• TIFF and GeoTIFF (*.tif, *.tif)
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• Portable Network Graphics (*.png)

MrSID, ECW and GeoTIFF images have their geo-location encoded within the image fle. Most 
images are accompanied by an additional small text fle, called a “world fle”. Planet will recognise 
the world fle, but if location information is embedded in the image fle, the world fle option will not
be selected automatically.

To capture a raster image, click Edit → Capture. Create a new feature class and select only “Raster”
for the allowed types. Ten click Select.

In the “Insert image” window, click Browse and select one or more images. (Please note that you can 
insert all your images in one step. Ctrl+A is an easy way to select all images in a folder or use the 
search function to list all images in all subfolders). 

World files
World fles describe the position, orientation and pixel size of images so that they can be accurately 
placed on a map. Tese fles have the same name as the image fle that they describe, but the 
extension is formed by taking the frst and last leter from the image fle's extension and adding a 
“w”. Te world fle for Image001.JPG will therefore be Image001.JGW.

Planet will automatically place an image in its correct location based on an accompanying world fle 
or encoded location information. In the absence of this information, you have the option to indicate 
a diagonal line on the map or enter coordinates.

Specifying coordinates or indicating corners on your map
If you have coordinates for a diagonal (two corners separated diagonally), you can enter them 
manually by selecting “Specify coordinates”. If there is no geo-location information available, your 
only option is to indicate a diagonal line on the map. Tis will normally be a rough estimation, but 
you will be able to improve the location aferwards.

Once your image is captured and appears on your map, you may want to improve locational 
accuracy by indicating a shif (translation) as well as a stretch (scale). Tese functions are under the 
Edit menu: Translate and Scale. Planet cannot yet do rotations and other transformations on raster
images.

Labelling Features
We labelled a feature during the exercise on page 59. Every feature has a special atribute called 
“Label” which you can edit in the Info tab. As soon as you enter a value for this atribute and save 
the change, you will see the feature labelled on the map. If you don't see a label the style used for 
rendering the feature does not include a font, or the label may have been dropped due to congestion 
on the map.

It is ofen useful to limit the scales at which features are labelled, and sometimes at diferent scales 
than other drawing elements. You might want to show the outlines (pen) of an administrative 
boundary to switch on at a certain scale, but only display the label (font) at a bigger scale (zoomed in
closer) to reduce cluter of text on your map. Another example would be to switch of the labels 
when zoomed in too much, e.g. you don’t necessarily need to see the name of a country at a scale of 
1:5000. Figure 13 on page 26 shows a font with limits on both minimum and maximum scale.
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Fixed vs automatic labelling
Te default labelling method of PlanetGIS is to distribute labels as evenly as possible while 
maintaining an obvious association between a feature and its label and omiting labels that will 
appear ambiguous. In some cases this is not ideal. Property boundaries, for example, are beter 
labelled at their centroid.

Figure 60 shows “Erven” set to display labels at the centroid of each polygon. Lines will be labelled 
at a point on the line that is exactly in the middle, measure along the line.

Placing static text on the map
Text is not a GIS “primitive” element (or in other words, a feature type). Some systems allow text, 
calling them “annotations”. In PlanetGIS2, static text can be placed on a map by labelling a point, but 
providing the display a style without a symbol and seting the “fxed placement” option. Te 
alignment of the font in use by the style will determine the relative position of the text to the 
(invisible) point.

Te “Orientation” atribute (an atribute immediately following “Label”) is used to determine the 
rotation of the text. 0º means “upright” text, or in other words the vertical axis of a leter points 
North. An orientation of 90º will have the vertical axis of a leter point East. Te degrees used for 
label orientation are geographic (compass) degrees, regardless of the coordinate system setings, and 
refer to the vertical axis if the leters. Te “Orientate to feature” label seting must be active for this 
behaviour.

Purely static text will also have the “Allow overlap” option set. Tis way you will be guaranteed to 
see the text. Tis is obviously not what you want, in most cases, when producing output maps.

Labelling from a database
Text from another atribute or detail table can also be used to label features. Select the source in the 
drop-down box in the Label tab of Display properties. (See Figure 60). Te disadvantages to this 
approach is that it can be slow to display a map for the frst time. Planet needs to load all the labels 
into memory (and keep it there) before the rendering of a map can be completed.

2 In PlanetGIS 3 and earlier, there was a feature type for text. Since version 4 the types of such feature classes is 
automatically changed to point.
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Figure 60: Label options for a display



Another disadvantage is that when changes occur in the database, Planet will not be aware of it, so 
labels need to be reloaded from the database. Re-opening the map will accomplish this, or pressing 
<Ctrl+F5> or holding <Ctrl> while clicking on the Redraw buton.
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Chapter 8

GOOGLE EARTH



Introduction
Google Earth is a very popular application that allows one to view satellite and orthophoto images 
from anywhere in the World. Te ability to capture ones own points, lines and polygons with 
Google Earth makes it an ideal tool to do GIS-like work with it. Google Earth is very “consumer 
oriented” and uses diferent terms for certain things than what a GIS professional will use. A point, 
for example is called a “place mark” and a line/polyline a “path” in GE.

To download Google Earth, go to this page: htp://www.google.com/earth/download/gep/agree.html 
and use “GEPFREE” as the license key when installing. Tis link if for Google Earth Pro, which has 
some advanced features over regular Google Earth.1 

The KML / KMZ standard
Google introduced a new text-based (XML) format for exchanging geographic information. Te fle 
format is large (being human readable), cumbersome and somewhat un-GIS-like. However it has 
become very popular and works well with Google Earth as long as feature count is limited to at most
a few thousand. Depending on your industry, you may be encountering KML fles more ofen than 
shapefles.

KML fles are used to exchange features between Google Earth and Planet GIS. KMZ fles are simply 
zipped versions of KML fles. To view the content of a KMZ fle, rename it to a .ZIP and unzip. (Te 
zip will contain a fle called “doc.kml” which can be opened with Notepad).

Troubleshooting Google Earth
All interaction with GE is through KML fles. Tere is no intra-program communication. To launch 
GE with a KML fle, Planet simply asks Windows to open the KML fle with the appropriate 
program. Tis means two things:

1. Google Earth must be installed correctly.

2. KML fles must be associated with Google Earth.

Sometimes the Windows association between KML fles are broken by other applications or 
manually. A re-installation of GE should fx the problem, alternatively you can check and repair the 
fle association by right-clicking on a .KML/.KMZ fle
in Windows' File Explorer, then click Open fithe 
(If you don't have a .KML/.KMZ, use Planet to create
one by exporting a feature: see “Exporting KML” in
next section).

If you need to browse for the executable, Google
Earth Pro is at C:\Program Files
(x86)\Google\Google Earth
Pro\client\googleearth.exe

Make sure you check “Always use the selected
program to open this kind of fle”.

You may have to repeat this process with a .KMZ fle
afer doing it with a .KML fle.

1 Since January 2015, Google Earth Pro is free: htp://google-latlong.blogspot.com/2015/01/google-earth-pro-is-now-
free.html
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Figure 61: Checking and repairing KML fle association
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Another form of troubleshooting is to inspect the KML fles that Planet produces. When not 
explicitly exporting to a KML/KMZ fle (i.e. View→In Google Earth→...), Planet creates .KML fles 
in your system's %TEMP% folder. To see where your temporary folder is, simply type %temp% in the 
“address bar” of Windows' File Explorer. Te fles that Planet created will look like planetxxxx.kml. 
Sort by “Date modifed” (descending) to easily spot them at the top of the list. If you now double-
click on one of the .KML fles, that is the same as what Planet does to launch GE. (Or right-click and 
Open withs to check the association).

Interacting with Google Earth
PlanetGIS has several useful ways to interact with Google Earth (“GE”). Te following main menu 
commands will take you directly to GE:

• Vief→In Google Earth→Current location
Zoom to same location and approximate scale.

• Vief→In Google Earth→Tags as placemarks
Current tags on the map are created as place marks (points).

• Vief→In Google Earth→Selected features
Selected features are exported to GE and displayed as an overlay.

Exporting KML
• File→Exporte 

Create .KML or .KMZ fles that can be used with GE.

As with other export formats, the File→Export menu item allows the creation of KML/KMZ fles 
with an options window. Tis option can be used either with one or more features selected, or if 
none are selected, you will be prompted to select one or more feature classes. First you need to enter
a name for the exported fle and select “Google Earth KML (*.kml)” or “Google Earth compressed 
KMZ (*.kmz)” in the “Save as type” drop-down list. You will then be presented with the following 
options window:
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Figure 62: Google Earth export options



• Export feature class as single placemark
Tis is the best way to show lots of features (many hundreds or thousands) on Google Earth 
without slowing or crashing it. Features will not be individually identifable (clickable). Tis 
is the frst option but not the default option. Te default option is second because it is related
to the options further down, which are not available for the frst option.

• Export features as identifable placemarks
Each feature will have it's own label and if you click on one, information about that feature 
will be shown in an “atribute balloon”.

• Display label
By default, the same label displayed in Planet will
be displayed in GE. You can also choose “None” or
a feld from an atribute or detail table.

• Attributes balloon
Select one or more felds from an atribute or
detail table to display in the atribute balloon. See
Figure 63.

• Open in Google Earth
If checked, the KML fle (GE) will be
automatically launched.

• Hover-over highlighting
Tis creates a GE style that shows each feature
with a slight fll when the mouse is over it. While useful it may be undesirable.

Importing KML
If you have features in Google Earth (vector objects as
opposed to images; see next section for images), they can be
exported to KML and then imported into PlanetGIS. Once you
close Google Earth, everything inside “My Places” is saved on
your computer but in a location not so easy to fnd2. Since this
is all in one fle, and you have to close GE to save to that fle, a
beter option is to right-click on the folder inside “My Places”
(or “Temporary Places”) in the “Places” tree and then click
“Save place as” (Figure 64). 

Choose a location that is easy to fnd from PlanetGIS and then
switch to PlanetGIS and click File→Import to import the KML/KMZ.

Capturing features in Google Earth
You capture features in Google Earth using the “Add Placemark”, “Add Polygon” or “Add Path” 

butons:  

First it is a good idea to create your own “folder” for your features. Give it a name, for example, of 
“My GE features”. If you want to capture features within feature classes, you need to create another 
level “folder” for each feature class.

2 Te fle containing everything in “My Places” is usually 
C:\Users\yourname\AppData\LocalLow\Google\GoogleEarth\myplaces.kml
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Figure 63: An atributes balloon in Google Earth

Figure 64: Saving a folder of features in Google 
Earth



Ten right-click on the new folder and click 
Add→Placemark (if you want to capture a point).  Give the
placemark/polygon/path a name and remember to move the
placemark or fnish capturing the polygon/path before closing
the properties window. 

Using Images from Google Earth
Google Earth Pro allows for images to be saved at resolutions
up to about 4800x3600. Tese images can then be captured in
PlanetGIS. If your accuracy requirements are high, you should use georeferenced orthorectifed 
images instead.

Seting up Google Earth Pro for saving images
1. Click File → Save → Save Image (or Ctrl+Alt+S). Tis will only activate the user interface 

that allows you to save images.

2. Uncheck everything in the “Map Options” drop-down list.

3. Choose the highest or preferred resolution in the “Resolution” drop-down list.

4. Navigating on Google Earth with the mouse will cause GE to tilt the image so that the focus of 
your view is not vertical. Tis can be disabled by clicking Tools → Options... and in the 
“Navigation” tab, choose “Do not automatically tilt while zooming”. Also increase the zoom 
speed in this tab.

5. Press “R” to reset the tilt (if any) and make sure North is up.

6. Switch of all layers (botom-lef, under “Places”). You can unchecked everything by unchecking 
“Primary Database”. It is especially important to have “Terrain” unchecked since the shape of 
the surface will afect the polygons you will be capturing in the steps below.

Steps to perform a “Google Grab”
Google Earth does not produce georeferenced images. You therefore have to position the images 
saved from GE yourself. Experience has shown the following steps to be the most efcient:

1. In PlanetGIS, choose a viewing area for which a single image from Google Earth will be 
appropriate. 

2. Click Vief → In Google Earth → Current location.

3. (Optional) It as advisable to maximize the GE window and keep the map area the same from this
point on. 

4. Capture a polygon to indicate the extents of the visible image:

1. Click the “Add Polygon” buton (next to “Add Placemark”).

2. Do not close the “New polygon” window as that will end the capture process. Position it 
so that it will be in the middle of your screen (all corners of the map visible). It is not 
necessary to give the polygon a name, but it is best to give it the name of the fles you 
will be saving in the next steps, eg. “GE1”.

3. Click once in each corner of the screen. Don't try to get too close to the corner, the 
accuracy of the polygon will be increased in the next step.

Google Earth 70

Figure 65: Create a folder under My Places in Google 
Earth



4. Click on each of the 4 vertices and drag them into the corners. If something goes wrong 
with this process, cancel the polygon and start over.

5. Click OK in the “New polygon” window.

6. You will see the polygon appear in “Places” on the lef. Right-click on it and click Save 
Place Ase

7. Save the polygon as a KMZ or KML in your working folder. Give it a name that you can 
easily identify, eg. GE1.kmz

8. Uncheck the polygon in Places so that it disappears from the map.

5. Click the “Save Images” buton at the top of the map and save the image with the same name as
the polygon (eg. GE1.jpg) in your working folder. Tis will take a short while.

6. Switch to PlanetGIS.

7. Import the .kmz/.kml fle of the polygon you saved from GE: File → Import and select the 
.kml/.kmz you saved. You will now see something approximating a rectangle on your map. 
Because of coordinate system transformations and the 3D surface shape in GE, one diagonal 
(e.g. top-lef to botom-right) may be more accurate than the other (e.g. botom-lef to top-right).
If you are inserting multiple images, trial-and-error will provide the answer.

8. Capture the .jpg image saved from GE: Edit → Capture and create a feature class for your GE 
images if you don't have one already, otherwise select it. Tis feature class must have only 
“Raster” selected for the allowed types.

9. Browse to your GE image (e.g. GE1.jpg) and choose “Indicate on map”. Click OK.

10. Now indicate a diagonal line by clicking on one corner of the imported polygon and then a 
diagonally opposite corner. Redraw or zoom out if you don't see the image.

Additional steps to improve positional accuracy
1. Find a location on the Google Earth image where a (required) shif is apparent compared to 

other existing features (e.g. cadastral boundaries not aligning with visible roads/fences). Tis 
should be either an obvious point feature or a bend (vertex) on a line/polygon.

2. Make sure the GE image is selected (and nothing else). Click on it and select the GE feature class
in the Info tab if necessary.

3. Click Edit → Translate and keep the default “Capture translation vector” option.

4. Click on a point on the GE image that needs to be moved to an existing feature, then click on 
the point to which it should be moved.

5. Tis specifc point will now be considered accurate (repeat from step 1 if not). Further steps will 
investigate whether a stretch (scale) will be necessary. You will have to come back to this point 
to indicate it as “fxed” if that is the case.

6. To determine if the image also needs to be stretched (scaled), fnd a location as far away as 
possible from the point you have been focusing on where a (required) shif is apparent. Tis 
location needs to be diagonally separated, i.e. both along the North-South axis and the East-
West axis. Failing this, small errors may result in large errors overall. If you don't see any 
obvious discrepancies, skip the following steps.
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7. If you have identifed a location, diagonally separated as far as possible from the initial location, 
that can be improved by an obvious shif to an existing feature, take careful note of it so that 
you can locate it afer going back to the initial point. Tip: use saved locations if these locations 
are hard to recognise visually.

8. Again make sure only the GE image is selected and then click Edit → Scale. Keep the default 
“Indicate” options for both the fxed point and the scale factor.

9. Navigate to the initial point and click on it to capture the fxed point.

10. Navigate to the second point and click once on the location that needs to be relocated, then on 
the target location.

11. Review the overall quality of positional accuracy and repeat from either step 1 or step 6 if 
necessary. Do not expect a high degree of accuracy with this method, though.
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Chapter 9

ATTRIBUTES



Introduction
“Atribute” is a GIS term for an item of information about a feature. In a
relational database, information is stored in “tables”. Each table consists of
rows and columns also sometimes called records and felds1. Each row (or
record) contains information for a specifc feature. Te row must contain a
FeatureId or other key feld that identifes the row as information for a
specifc feature.

Each database table typically has a diferent set of columns (with diferent
names and data types). Tis is also called the “structure” of the table. One of
the main reasons for having diferent feature classes is to have diferent tables
with diferent structures assigned to the feature classes, in order to store
information that is appropriate to each feature class.

The Info tab

To see the atributes of a feature, activate Tag mode ( ) and click on a

feature. Using the World Map, click on Cape Town and expand the Info tab
by clicking on it. Figure 66 shows the info tab with the Cape Town “Places”
feature selected.

Te top part of the Info tab shows the feature class (“Places”) that has been
tagged on the map and also feature classes of underlying features which you
may have intended to select. To view atributes of the country instead, click
on “Countries”.

Next is the FeatureId. If more than one feature has been selected, the drop-
down list needs to be used to see the atributes of individual features.

Next is a tool bar with butons to save changes, cancel changes, print and
“tabular view”. 

Te rest of the Info tab shows all atributes of the selected feature. You can
change any value by clicking in the white box and typing a value.

Tip: To extract the atributes for use in another application, click “Tabular
view” in the toolbar; then right-click on the data sheet and click “All rows”
followed by “Copy to clipboard' or “Open as spreadsheet”.

Note also the “Information” items at the top. Tese are detail tables set up to
take you to Wikipedia for more information. Click on the hyper-linked
atribute name to go to Wikipedia.

Common atributes
Now use the scrollbar to scroll to the botom-most atribute, until you see “Add atribute”. Te last 13
atributes are common to all features. (Tey belong to the root feature class. Features are 
“subclassed” in order to specify atributes that are more appropriate to their type). Tese are:

• FeatureClassId
Specifes which feature class the feature belongs to.

1 A feld, more accurately, is the space provided to display or enter a value. Tis space isn't necessarily in a tabular 
format.
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• Easting, Northing, Altitude
Coordinate of point, centroid of line or polygon.

• Measure
Any numeric measurement associated with the feature.

• Label
Text to display on the map.

• Orientation
Point features can have an orientation: 0 degrees is North, 90° is East.

• Geometry
Tis is a BLOB (Binary Large Object) feld containing the geometry (all coordinates) of the 
feature.

• Length
Length of a line feature; perimeter of a polygon in coordinate system units (usually metres).

• Area
Surface area of polygon in square coordinate system units (usually sqm).

• Deleted
Contains the value 1 if feature is deleted.

• RevisionId
Every change to a feature's geometry increments a revision number which is stored here.

• Key1
User defned identifer for the feature, can be a number or text. (More keys may be added if 
needed).

Defining a new atribute column
Before you can enter atribute information for a feature, a
column needs to be added to the atribute table for the
feature's feature class.

A short-cut way to add an atribute column is to click on the
hyper-linked “Add atribute” at the botom of the list of
atributes.

Column name may contain spaces, although most database
administrators prefer underscores (_). Avoid special
characters, especially the period (.). With Planet's built-in
SQL engine, commas (,) ampersands (&) and most special
characters are allowed, but they make it more difcult to export information to other database 
systems.

Te following column types are available (Te descriptions are for Planet's built-in SQL engine. It 
will vary with other database systems): 

• Integer – whole numbers; signed 64 bit integer with a range of -9,223,372,036,854,775,808 to
+9,223,372,036,854,775,807.

• Numeric – whole numbers and foating point numbers; IEEE 754 64 bit double precision 
with a range of 10-308 to 10308, with 15 decimal digits precision.
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• Text – Character string of unlimited length; UTF-8.

• Binary data – BLOB (Binary Large Object) of unlimited size.

• Yes / No – Boolean True / False stored as 1 or 0.

• Date and time – Stored internally as a foating point Julian Day number2.

• Other – you can defne any other type that the database engine will understand.

Column defnition is the database specifc type for the above. An expert might be interested in 
changing it.

Default value can be chosen from the drop-down list or you can supply your own.

At the botom of the screen you will see the SQL statement that will be executed to alter the 
database structure. Tis is one of a few places where Planet will show you SQL and it is a handy 
feature to teach yourself SQL (Structured Qery Language).

Click Add to create the new atribute column. You will notice that the new feld is not created at the 
botom. Te feld is added to the feature class' own atributes which are shown frst. Look for the last
item just before the divider that separates the specifc atributes from the general (root) atributes.

To delete an atribute feld and for more advanced restructuring of database tables, you can use the 

Database Manager ( ).

Multiple selections

To clear your selection, click Clear tags ( ,

second last buton on the lef).

Check that you are still in Tag mode and note the
hint at the botom of the screen when the mouse
cursor is over the map. Te hint instructs, among
other things “Ctrl+click multi-selects”. If you hold
down the [Ctrl] buton you will also see that the
mouse cursor changes to include a plus (+) sign.
Now click on Saldanha, Vanhynsdorp and
Springbok while keeping the [Ctrl] buton
pressed. (You may have to zoom in to the west coast
if they are not visible).

Figure 68 shows the multiple selection. Note the
correspondence between the FeatureIds in the
yellow tags on the map and the FeatureIds in the
drop-down list in the Atributes tab. 

Notice how some atributes appear with a black font and some with a grey font. Atribute values 
appearing in black are the same for all selected features, while atribute values appearing in grey are 
diferent.

Select a FeatureId in the drop-down list to see the atributes of only one feature. (All atributes will 
appear black). Now change any atribute, e.g. “scalerank” to a diferent value. Te feld area will turn 
yellow to alert you that the value has changed and needs to be saved. Te Post changes buton 
(check mark buton in the toolbar) will save the change(s) to the database.

2 A Julian Day number is the number of days since noon in Greenwich on November 24, 4714 B.C. according to the 
proleptic Gregorian calendar. Te fractional part determines the time, 0 being noon and +0.5 midnight.
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Multi-feature atribute capture
A very useful function of Planet is to capture the same atribute for multiple features simultaneously.

Select “All records” again for the FeatureId and change any value. Te feld area will now turn red, 
alerting you that multiple records will be updated in the database if you save the changes.

Clicking on any of the grey values will assume that value for all features (unless you change it). Tis 
is most useful when you have one feature with data and then select other features with no data, but 
you know that certain atributes are the same. A single click on all atribute values that must be the 
same for all selected features (and the Save buton) and you have captured data for all selected 
features without atributes.

Only changes are posted to the database. Atribute felds coloured yellow or red will be updated in 
the database. Fields with a white background will remain untouched.

Lookup lists
Lookup lists (ofen called “lookup tables”) are used to pick values from a list instead of entering them
by hand. Lookup lists can reduce input errors and restrict input values to a predefned set.  To defne 

your own lookup lists, activate the Database Manager ( ) and select the database connection of 

your project. For a database connection, the frst tab will be “Lookup lists”.

Right-click in the Lookup lists box and select Nef list, then enter a name. If you have many 
lookup lists, create lists with sub-lists. Figure 69 shows a project with many lookup lists, organized 
into sub-lists.

With a list selected, you can enter values in the Display value box and click on the Add buton. If 
you already have the values in a word processor (or Notepad) you can copy them to the clipboard 
and paste them with the Paste buton. (Values need to be one per line).

If you want users to be able to add new values while capturing information, check Allof nef 
values. If you want to discontinue using a list, check Hide list. Tis ensures that any existing 
atributes using the list can still fnd it.

Tip: to copy lookup lists, or even groups of lists, to another project, simply drag them onto the 
database connection of another opened project.
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A lookup item has a unique ID (unique inside the project database) that will be stored if the lookup 
is used with an Integer column. Lookups on Text columns will cause the display value to be stored3.

Ataching a lookup list to an atribute

Te easiest way to atach a lookup list to a column (atribute) is to

use Design mode ( ), click on the feature class and then the 

Attributes tab. Ten, next to the feld for which you want to assign
a lookup list (and in the column for “Lookup table”), right-click to
select the lookup list.

Now click on a country and you will see a dropdown list for the
“type” atribute in the Info tab. (See Figure 71).

You can also atach a lookup list in the Database Manager. Locate
the feature class' atribute table (starts with f_; expand the “f” node)
and click on the Structure tab.  

3 Some database administrators may frown upon storing text instead of an Id, but in the real world this is common and 
it may simplify things. Storing an Id saves space and allows for the display values to be changed easily, but 
inadvertently deleting a lookup list will cause data loss. You also cannot copy tables containing lookup Ids to other 
projects, unless you are certain that the projects have identical sets of lookup lists.
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Popup Info

An alternative to using the Info tab on the right, is to use the “Info” click mode ( ) instead of 

“Tag”. Tis provides more space for atribute information and may be a good alternative when using 
multiple monitors.

Multi-media content

Linking content to regular atribute fields
Any computer fle can be linked as an atribute. When the fle resides on the same storage media 
(“drive”) as the Planet project, a relative path should be stored to keep the link portable. If the fle is 
on a diferent drive, on a network location, or the Internet, the link will have to be absolute and the 
fle will only be accessible if the media is connected.

If you want to link fles to a project and be able to redistribute them together with your Planet 
project, it is best to keep such fles in a subdirectory inside the directory (or “folder”) where the 
PlanetGIS project fles reside.

To link such a fle to a feature, you can simply enter the (relative, if possible) path to the fle as a text
atribute. For example, if you have survey diagrams for property boundaries, you would create a 
subdirectory called “Diagrams” inside your project directory and then enter a relative path as a text 
atribute. If the fle is named 0004ZX02.TIF, (and inside a “Diagrams” subdirectory) you would enter 
the link as “Diagrams\0004ZX02.TIF”. Once you save the atribute, you will see that the name of the 
atribute becomes hyperlinked (blue and underlined). You can now click on the hyperlink to open 
the fle with the default application set up on your system for viewing fles of that type. It is your 
own responsibility to ensure that fles of the type that you are linking (fles with the same extension)
can be opened on your computer. In other words, you must be able to double-click on it in Windows'
File Explorer (or the desktop) and an appropriate application must then be launched by Windows to 
view the fle.
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Te completely correct way to enter a relative path to a fle into a subdirectory is to start the path 
with a .\ (dot backslash). A single dot means current directory, and a double dot the parent 
directory. So, if for example the “Diagrams” directory (or folder, if you prefers) was outside of your 
project directory and on the same level, the relative path would be “..\Diagrams\0004ZX02.TIF”. 
Starting the relative path with a .\ also gives Planet an indication that the atribute is a path to a 
fle. Planet recognises common fle types, e.g. .doc, .jpg, .xls, .pdf, etc. but to be completely explicit 
that an atribute is a link to a fle, and especially if the fle is also not relative, you need to prefx it 
with “fle://”. So in the above example, “fle://./Diagrams/0004ZX02.TIF”. (Notice how my word 
processor automatically “hyperlinked” it?)

Now that you know how it works, there is an easy way capture links to fles on your computer or 
your network: drag them from Windows' File Explorer and drop them onto an atribute feld. You'll 
need to place File Explorer and Planet side-by-side, or use a second screen. (See Figure 73).

Instead of a fle, you can also link to an entire folder. If a folder is linked Planet will open File 
Explorer to show the contents of the folder.

Multiple links are also possible: select more than one fle and drop them onto a text atribute feld. 
Te only caveat with this is that the hyperlink will open them all at once – not suitable for more 
than a handful links.

Lastly, you can also link to content on the Internet. “www.planetgis.co.za” will take you to the 
PlanetGIS website. Remember to save the atribute, you will see the hyperlink afer saving. Te 
“www.” tells Planet (and Windows) that it is an Internet link, but some web pages do not start with 
www. Te best way to link to a website is to start with “htp://”. Documents

PlanetGIS 5 has a built-in document manager for a much more structured method to link documents 

to features. Te document manager resides in the “Documents” tab ( ). To add a document, expand 
the Documents tab and right-click on the white space (or existing document thumbnail). You need to
have at least one feature selected.

Ten click Add and you will be presented with the diferent options for adding or linking 
documents.

• Store document(s) in database
Tis is the recommended option unless database size is an issue or documents are accessed 
from a central server.
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• Link to document location(s)
Similar to linking documents in the previous section, but still beter for multiple links.

• Link to folder
Also similar to the previous section, but beter for multiple links.

• Link to document already in database
Search the database for documents already stored.

Te Brofse buton allows you to select any number of documents
accessible to your system and the Search buton allows for searching
of documents of a specifed type.

When storing a document in the database, Planet will not store a
duplicate if the document is already in the database, but instead only
create a link between the selected feature and the existing document. It
is therefore safe to use the frst option even you intend to link to an
existing document.

To see or capture metadata for a document, click on the thumbnail. To
open the document, click on the thumbnail in the information window.

Info tab vs documents tab
Documents can also be linked or viewed in the Info tab. (Right-click on
a feature class to add documents and photographs). Te Documents tab
is more convenient for looking at documents of a multi-feature
selection. In the Info tab, you need to navigate to a specifc feature (or
other type of) class.

Te Documents tab also provides flters: feature class, component class,
tags and date. Te date flter is especially useful when you want to look
at documents created/modifed in a certain year, with the option to
drill down to a specifc month.

Tagging
Documents (and photographs) can be tagged to create a hierarchical
(directory) structure. Use the “Tags” atribute feld of documents to
store tags. To create sub-levels use the backslash character (“\”). For example, you might tag one 
document as “Applications\Pending” and another as “Applications\Approved”. 

You can also use multiple tags separated by a comma (“,”) to have a document appear in multiple 
“nodes” of your tag structure.

When importing a whole directory and subdirectory of documents (using the Search buton when 
adding documents) you have the option to store the directory names as tags. Tis is a handy way to 
retain the original structure of your documents.

Use the Tags flter (fourth buton at the top of the Documents tab) to see the tag structure and to 
flter to specifc node.
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Photographs
Photographs & sketches are another form of atributes. Activate the Photos tab
and right-click on the white-space to add a photograph. (Tis can only be done
when a single feature is selected). You can load any number of photographs for a
feature and they will be displayed as thumbnails. Click on a thumbnail to view the
original size image.

Use the mouse wheel or click to zoom in (right-click to zoom out) and drag the
mouse to pan (if zoomed in). Use the up and down arrows on the keyboard (or 
PgUp and PgDn) to view the previous or next image.

If the photographs were taken by a camera with a gravity sensor (most smart
phones), Planet will rotate the photographs so that the correct edge is “up”. If this
information is not available inside the JPEG, you can manually rotate photographs
by right-clicking on them.

You can also right-click → Copy to get the full resolution image on the clipboard,
for pasting into another application or right-click → Save ass or Prints to launch
Windows' “Print Pictures” application.

When viewing the full resolution image, you can also adjust the brightness and
contrast (last buton next to Print, Copy and Save to fle). You can also leave the
full resolution image open and open other photographs for comparison or capture
atribute information for the selected feature. (Move the photograph window
away to keep interacting with PlanetGIS). Tis is most useful when using multiple monitors and 
when capturing information which is being interpreted from a photograph.

PlanetGIS can also display panoramic images which are projected onto the inside of a three-
dimensional sphere. Tese images are typically produced by specialized hardware on a tripod or 
stitched together from multiple images. Currently, any image with a width of twice or more than its 
height is assumed to be a panorama image.

Sketches
You can create your own freehand and line drawings in the Sketch tab. Tis function is especially 
useful on a hand-held device with a stylus. Figure 76 shows the sketch drawing functions.
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Detail tables
Detail tables are another way to connect information to features. Te name “Detail” is because of the
concept of a master-detail relation in relational databases (sometimes also called “foreign key”). A 
Detail table has an (indexed) column/feld with values that correspond to values in a column/feld4 of
a master table (“key”).

Atribute tables always have a FeatureId as the primary key. Tis means that an atribute table 
contains only one row of information for each feature5. Detail tables, on the other hand, may contain
multiple rows for each feature, if allowed when creating the detail table link.

Detail tables can be connected to any atribute (which makes that atribute a “key”), but typically 
this is either the FeatureId column or the Key1 column. When using FeatureId, keep in mind that 
FeatureIds can change, for example when re-importing features or copying them to a diferent 
feature class.

Detail tables are used in the following situations:

• Linking to information in tables other than atribute tables

• Linking to tables with multiple rows of information per feature

• Linking to tables in an external database

• To use SQL to present information (e.g. the Wikipedia link of countries in the World map)

• To add additional levels of master-detail relations (a detail table becomes another’s master)

Creating a detail table
When you “create” a detail table in PlanetGIS, you are actually only creating a link to a table. If the 
table is inside Planet’s database you will have had to create or import the table in the Database 
Manager (see below). Use Design Mode to create a detail table (link). Expand “Feature classes” and 
expand a feature class to right-click on the “Detail tables” node, then click Nef or right-click on the 
feature class and click Nef→Detail table.

If the table is internal to your project, you only have to select the table from the drop-down list in 
the frst tab. For external tables, see Connecting to databases.

In the second (“Master-detail”) tab, you need to select a master column (e.g. features.FeatureId or 
features.Key1) and an index column for the table you are linking. If you don’t see any columns when
selecting the index, an index needs to be created. (See next section).

Change “One-to-one” to “One-to-many” if you expect more than one row to be linked to a feature.

Creating an empty detail table
If you are starting with no data, create a detail table by right-clicking on your project’s database 
connection in the Database Manager, then click Create tablee

4 In relational database theory, a table is a matrix of columns and rows. However, it is common to refer to these as 
records and felds. While record and row might be the same, a feld is really the intersection of the row and column (or
a cell). To this author, felds and records are more appropriate when referring to the spaces in a user interface for 
entering or viewing the content of a table, while column & row is more abstract and relates beter to describing a 
table. htp://dba.stackexchange.com/questions/310805/what-is-the-diference-between-a-record-and-a-row-in-sql-server
To complicate things further, in GIS an atribute is a cell/feld value, but when thinking about the structure of a table 
(e.g. adding an atribute/column/feld) you are really referring to the existence of the whole column, not adding any 
data.

5 Specialized atribute tables start with “f_” while the main atribute table is “features”. f_ tables can have zero rows if a 
feature doesn’t have any specialized atribute information.
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Enter a name for your table. Te
convention in Planet is to use lower-
case leters and underscores, but for
detail tables it is a good idea to
capitalize the frst leter so that it
appears at the top of table selection
lists. It is a good way to distinguish
tables you created/imported yourself
from tables that were created by
Planet. You can use spaces in table
names (and columns) if you want.
Te convention in Planet for column
names is to use CamelCase and no
spaces.

For any changes to be allowed on a
detail table, it must have a primary
key. In Figure 77, the frst column is
type “Integer” and “Primary key” is
checked. Click Add to start the list of
column defnitions. Tis frst column will simply contain numbers starting at 1 and incrementing for
each row. Tis value will not be of much interest to us, but is needed for making changes to the 
table.

Now add columns to contain your
own information, but start with the
column that will be used to link the
information to features. In this
example (using the World map), we
add a column named “CountryCode”
of type “Text”. It is important to
uncheck “Primary key” before
adding, but for this column we need
to create an index, so click “Indexed”
instead. Before adding the next
column (“VisitDate” of type
“DateTime”), be sure to uncheck
“Indexed”. Te last column in our
example is “VisitDuration” of type
“Integer”). (See Figure 5). Now click 
Execute.

Now this table needs to be linked to the Countries feature class as described above. In the “General” 
tab, select the table “Visits_to_country” as the “Existing dataset” and select values as shown in
Figure 79 for the “Master-detail” tab.
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Figure 77: Creating a new table

Figure 78: Adding columns



Figure 79: Detail table master-detail relation

Now go to Map mode and click on a country to test the detail table. To capture a visit, select a date 
for VisitDate and enter a number of days for VisitDuration. It is not necessary to enter the Id or 
CountryCode as Planet will do that for you.

Importing a detail table
To get non-spatial data into your project there are 3 options:

• Comma Separated Values (CSV)

• dBase (DBF)

• SQL connection

Te frst two options are normally spreadsheet data. If you have information in an Excel (or Calc, 
etc.) spreadsheet, make sure the frst row contains column names6 and then Save as a “Comma 
Separated Values” (.CSV) fle. (Make sure you save changes to the spreadsheet to the native format 
frst (e.g. .xlsx, .ods) and multiple sheets will have to be saved as separate CSVs). It is also important 
to close the spreadsheet because the spreadsheet sofware will lock the fle afer Save as. If your 
spreadsheet sofware has a “Save a Copys” facility, you don’t need to close the spreadsheet.

In the Database Manager, right-click on the database connection for your project and click 
Import→CSVe and browse for the .CSV fle with the ellipsis buton. 

6 Also check for empty rows, sub-totals and totals when converting a spreadsheet to a CSV fle. Tose could cause 
trouble.
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Figure 80: Entering data into a detail table



As an exercise, you can download GDP data from the World Bank’s website: 
htp://data.worldbank.org/indicator/NY.GDP.MKTP.CD   Tere is a CSV and an Excel version, but 
the frst row does not contain column names, so you might as well download the Excel sheet. Go to 
the frst (“Data”) tab and delete the frst 3 rows. Ten Save as, or Save a Copy to a CSV fle taking 
note of the location. In Planet, select the CSV fle in the “CSV import options” screen.

Figure 81 shows the CSV import options window. If you don’t see the columns as a list (but all 
together as a single item) it means you need to change the delimiter character, most likely to a semi-
colon. You can also click the Vief contente buton to make sure that Planet is interpreting the 
CSV correctly. Click on all to select all the columns and change the table name to “Country_GDP” 
(the current name, while it will work, is VERY database-unfriendly). 

Te next step is to create an index on the column “Country Code”. You can right-click on the table 
on the lef and select Alter table... or click on the “Structure” tab, then right-click on one of the 
column defnitions and select Restructure table... Ten select the “Country Code” feld and check 
Indexed, click the Update buton and click Execute. See Figure 82.
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Now you can link this detail table to the “Countries” feature class. Go to Design Mode and locate the
Countries feature class. Expand the node and right-click on “Detail tables”, then click Nef. Enter 
“GDP” for the detail table description and select “Country_GDP” for “Existing dataset”. In the 
“Master-detail” tab, select columns as shown in Figure 83.

Now go back to the map and click on a country. In the Info tab you will see GDP information.
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Figure 82: Creating an index on a detail table

Figure 83: Seting up a link to a detail table
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Chapter 10

IMPORTING AND EXPORTING 
INFORMATION



Introduction
PlanetGIS can import and export spatial and atribute information from and to many formats. When 
importing and exporting spatial data (features), care must be taken to set up the correct coordinate 
system before importing and possibly convert the coordinate system before exporting. If the source 
or target is geographic coordinates (latitude & longitude), this is normally not an issue as long as the
datum stays the same (normally WGS84). Projected (local) coordinate systems can always convert 
coordinates to and from latitude & longitude (of the same datum). See Chapter 4 for more 
information on coordinate systems.

Tere are three diferent paths for importing and exporting information:

• GIS exchange fles – physical fles containing geometries and (sometimes) atributes.

• Geo-databases – a database fle or SQL connection to a server with tables containing 
coordinates or geometries.

• Spreadsheets (CSV fles) – information can be opened immediately in a spreadsheet or 
placed on the clipboard.

Earlier versions of PlanetGIS could open many exchange fles directly by creating a temporary 
project and importing them. More recent versions of PlanetGIS requires a project to be created frst 
(and a matching coordinate system selected) into which exchange fles can be imported.

To import an exchange fle, click File → Import and browse to select the fle. Depending on the 
type of exchange fle, diferent options windows will be presented as discussed below. You can also 
right-click on the Feature classes node or on a specifc feature class in Design to import exchange 
fles.

To export an exchange fle, frst make sure you have one or more features selected, or if you want to 
export entire feature classes then make sure that nothing is selected on the map. Ten click File → 
Export and select a fle type and destination. If nothing was selected on the map, you will frst be 
prompted to select one or more feature classes. You can also right-click on a feature class in Design 
or on a display in the Displays tab to export to an exchange fle.

ESRI™ shapefiles 
A “shapefle” is a format of spatial and atribute data exchange, introduced by ArcView 2 in the early
90's. Shapefles are the most commonly used format for exchanging GIS information.

A shapefle is actually a collection of fles with the same name, but diferent extensions and stored in
the same directory. Tere can be around 10 diferent fles, of which 3 are mandatory:

• .shp – feature geometries

• .shx – index for the .shp

• .dbf – atributes in dBase IV format1

From now on, “shapefle” will refer to all three. PlanetGIS ignores any other fles, and is able to open 
a .shp without the other two mandatory fles present. 

A fourth fle with a .prj extension is starting to become mandatory in practice. Tis is a text fle 
containing the coordinate system parameters and is useful in determining the shapefle's coordinate 
system. If this fle starts with GEOGCS["GCS_WGS_1984"… then the shapefle contains geographic 

1 One of the biggest drawbacks to shapefles is the storage of atribute data in dBase IV format, which among other 
limitations, limits feld names to 10 characters.
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coordinates (latitude & longitude) and can be imported into either a geographic or projected 
coordinate system that is based on WGS84 (eg. Hartebeesthoek94). If this fle starts with GEOGCS but 
a diferent datum, you must ensure the datum of your project is the same or equivalent before 
importing the shapefle. If this fle starts with PROJCS, that will be followed by the name of the 
coordinate system and it must be the same or equivalent to the PlanetGIS project's coordinate 
system before you import.

Importing a shapefile
1. Click File → Import and browse to fnd one or more shapefles (you can select many shapefles

at once).

2. An options window will be presented for each shapefle selected. Importing will only start once 
all the options windows have been dismissed. Tis allows for unatended operation of lengthy 
imports. In most cases, the frst decision to be made for each shapefle is the atribute feld to 
choose for labelling features.
Te frst step, therefore, is to
click on the Preview tab in
order to see the content of the
.dbf

3. Figure 84 shows that one of
the columns, “name” is likely
the best choice for the feature
label.

4. Now go back to the Source tab
and select “name” for the label.

5. Te orientation values are 
for rotated text, where the 
rotation angle is specifed 
as an atribute.

6. Also use the Preview tab to
decide which atributes to 
import, or simply click all.

7. Te actions tab will be 
discussed later in this 
chapter. For frst-time 
imports, it is not necessary 
to change anything. 

8. Now click Import. If multiple shapefles were selected, repeat from step 3.
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Figure 84: Previewing the .dbf of "a shapefle"

Figure 85: Selecting a label and atributes for shapefle import



Exporting a shapefile
1. To export a shapefle, click File → Export. If there are no features selected on the map, Planet 

will ask you to select one or more feature classes to export.

2. Browse to a directory where the shapefle will be created. Planet automatically gives the 
shapefle the name of the selected feature class, but you can change it if necessary. 

3. A shapefle options window will be presented for each feature class to be exported. In this 
window you can change the name of the shapefle, select which atributes to export and specify 
a detail table which felds will be added to the atributes.

4. If your map selection contains multiple feature classes or you have chosen more than one 
feature class,  successive options windows will be presented for each. Planet will not ask you to 
specify the location and name of each with the Windows “browse” function, but you can change
the name of each in the options window, or click on the s buton to use the browse function.

5. Finally, if you are exporting a feature class containing multiple types, Planet will create 
additional shapefles for each type and append “_points”, “_lines” or “_polygons” as appropriate,
since shapefles can only store one type of feature in each fle.

Additional ways to export shapefles are to right-click on a display in the Displays tab or on a 
feature class in Design.

Google Earth™ KML/KMZ
Many people are using Google Earth as a GIS. In some cases it can be convenient to capture features 
in Google Earth and then import them into Planet. In many cases Google Earth is an excellent way 
for people to visualize a small number of features without needing GIS sofware. For this reason, 
KML/KMZ is becoming more and more prevalent and will perhaps one day surpass shapefles. See 
the chapter on Google Earth starting on page 66 for more detail on using Google Earth.

Instructions for importing and exporting KML/KMZ are on page 68.

AutoCAD™ DXF

GPS Exchange files (GPX)

Geotagged photographs (JPG)

Spreadsheet information (CSV)

Geo-databases
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Chapter 11

THEMATIC MAPPING



Introduction
Te true power of GIS presents itself with what is called “thematic mapping”. In the broadest sense a
thematic map is a map that illustrates a “theme” or, if you will, “tells a story”. More specifcally, in 
PlanetGIS a thematic map is one that has at least one classifcation of features into separate 
“thematic layers”. In Planet, this is called a “thematic query” because of the similarity to SQL queries.

It is possible to create thematic maps without using thematic queries. For example, to highlight a 
property boundary to stand out, you can simply copy it to a new feature class, add that class into a 
view and assign a (new) style to the display that stands out from other property boundaries. In this 
chapter we will not be doing that, but use atributes to determine the appearance of the map. Te 
advantage to this approach is that when the data changes, so does the map.

To create a thematic query, either use Tools→Tematic mapping→Create thematic querye in 
Map Mode or use Design Mode to create thematic queries for a feature class (expand Feature classes 
and then the feature class on which you want to base the query and you will see a node called 
Tematic queries – right-click, then Nef→Tematic query).

Figure 86: Creating a thematic query in Design Mode

A thematic query will also, typically, be used in a new View, which must be set up to contain 
background mapping to provide context. Figure 87 shows the creation of a new view, which will be 
needed for the next example. Right-click on the last view tab and select Nef vief→Afer this 
vief, then provide a name such as “Visited”.

Figure 87: Creating a new view

Te next step will be to add context. In the Displays tab, add (for example) “Countries” and “Land 
cover”. Design mode can also be used to create views and to copy displays from other view by 
dragging and dropping.
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Select queries
Te simplest type of thematic query is a “Select query”. Te result is a single layer containing a 
subset of the feature class. Tis is basically a flter used to highlight features based on constraints set
on one or more atribute values.

Te simplest select query is one used to highlight
features that have information in a detail table. Figure 
88 shows a query using the detail table we created in the
previous chapter. Te query needs a descriptive name,
an atribute or detail table and a type. Here the “Visits”
detail table is selected and the type set to “Select”.
Nothing more is required other than to run the query
and add it into a view. Tis .query warns the user that
the master column isn’t indexed, but with a small
project the speed degradation is not noticeable.

In the Displays tab, add the thematic (expand
“Countries” to see the new thematic). Now you will see
all countries with data in the “Visits” detail table stand
out with a solid colour. To change the style to
something else, right-click on the display and click 
Style propertiese

To make changes to a query, you can also use the
Displays tab: right-click the display that references the
query and click Tematic query→Properties... at the botom.

Group queries
Group queries put features with the same atribute values together in a sub-layer. In other words 
“classify by value”. An example of a group query is the query in the World map that gives each 
continent a unique colour.

Range queries
Range queries divide features based on numeric atributes into predefned ranges.

Pie and Bar charts
Pie and Bar charts are a variation of a group query, where a pie slice or a bar is a “classify by value” 
with another atribute used to determine the relative sizes.
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